summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ecb4b2f5038..0dc8132d04fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = xde-theme-blackbirds
pkgdesc = SR-71 Blackbird theme pack for XDE
- pkgver = 1.2.4
+ pkgver = 1.2.5
pkgrel = 1
url = http://www.unexicon.com/
arch = any
groups = xde
license = CCPL:by-nc-nd
+ makedepends = git
depends = xde-styles
- source = xde-theme-blackbirds-1.2.4.tar.gz::https://github.com/bbidulock/xde-theme-blackbirds/archive/refs/tags/1.2.4.tar.gz
- md5sums = 928a714279a3b6849932c55c7ff0c0e5
+ source = xde-theme-blackbirds::git+https://github.com/bbidulock/xde-theme-blackbirds.git#commit=cdd1bc552200892e36d68fc25f1d3d63dba01e40
+ md5sums = SKIP
pkgname = xde-theme-blackbirds
diff --git a/PKGBUILD b/PKGBUILD
index a8b00801c4f1..16a5a8ff078b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,34 @@
#Contributor: Brian Bidulock <bidulock@openss7.org>
pkgdesc="SR-71 Blackbird theme pack for XDE"
pkgname=xde-theme-blackbirds
-pkgver=1.2.4
+_commit=cdd1bc552200892e36d68fc25f1d3d63dba01e40
+pkgver=1.2.5
pkgrel=1
url="http://www.unexicon.com/"
license=('CCPL:by-nc-nd')
arch=('any')
groups=('xde')
depends=('xde-styles')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bbidulock/$pkgname/archive/refs/tags/$pkgver.tar.gz")
-md5sums=('928a714279a3b6849932c55c7ff0c0e5')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/bbidulock/xde-theme-blackbirds.git#commit=$_commit")
+md5sums=('SKIP')
+
+# Leaving this for pkgver bumps, not really needed for users hence commenting out.
+#pkgver() {
+# cd $pkgname
+# ./autogen.sh
+# ./configure --version|head -1|awk '{print$3}'
+#
+#}
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
make DESTDIR="$pkgdir" install
}