summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
-rw-r--r--xdg-launch-git.install14
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43395e6b5527
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xdg-launch-git
+ pkgdesc = A command line XDG compliant launcher
+ pkgver = 0.4.r0.g6668df0
+ pkgrel = 1
+ url = http://github.com/bbidulock/xdg-launch
+ install = xdg-launch-git.install
+ arch = i686
+ arch = x86_64
+ groups = xde
+ license = GPL
+ makedepends = git
+ makedepends = pkgconfig
+ depends = desktop-file-utils
+ depends = gtk2
+ depends = libnotify
+ depends = startup-notification
+ optdepends = dmenu: to use dmenu_launch script
+ provides = xdg-launch
+ conflicts = xdg-launch
+ source = xdg-launch-git::git+https://github.com/bbidulock/xdg-launch
+ md5sums = SKIP
+
+pkgname = xdg-launch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf7596814fff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=xdg-launch-git
+pkgver=0.4.r0.g6668df0
+pkgrel=1
+pkgdesc="A command line XDG compliant launcher"
+arch=('i686' 'x86_64')
+url="http://github.com/bbidulock/xdg-launch"
+license=('GPL')
+groups=('xde')
+provides=('xdg-launch')
+conflicts=('xdg-launch')
+depends=('desktop-file-utils' 'gtk2' 'libnotify' 'startup-notification')
+optdepends=('dmenu: to use dmenu_launch script')
+makedepends=('git' 'pkgconfig')
+install="${pkgname}.install"
+source=("${pkgname}::git+https://github.com/bbidulock/xdg-launch")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long --tags | sed -r 's,([^-]*-g),r\1,;s,-,.,g'
+}
+
+prepare() {
+ cd ${pkgname}
+ ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make V=0
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xdg-launch-git.install b/xdg-launch-git.install
new file mode 100644
index 000000000000..98965c989a92
--- /dev/null
+++ b/xdg-launch-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+