summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0898aa393a07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xdg-su-git
+ pkgdesc = Run a program as root with a graphical interface
+ pkgver = 1.2.3.r0.g5c1f1f5
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/tarakbumba/xdg-su
+ arch = any
+ license = MIT
+ makedepends = links
+ makedepends = xmlto
+ makedepends = git
+ makedepends = docbook-xsl
+ depends = bash
+ provides = xdg-su
+ conflicts = xdg-su
+ source = xdg-su-git::git+https://github.com/tarakbumba/xdg-su.git
+ md5sums = SKIP
+
+pkgname = xdg-su-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba328e6d00e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Atilla ÖNTAŞ <tarakbumba@gmail.com>
+# Contributor: Mitchell Nemitz <mitchell.nemitz@gmail.com>
+pkgname=xdg-su-git
+pkgver=1.2.3.r0.g5c1f1f5
+pkgrel=1
+pkgdesc="Run a program as root with a graphical interface"
+epoch=1
+arch=('any')
+url="https://github.com/tarakbumba/xdg-su"
+license=('MIT')
+makedepends=('links' 'xmlto' 'git' 'docbook-xsl')
+provides=('xdg-su')
+conflicts=('xdg-su')
+depends=('bash')
+source=("$pkgname::git+https://github.com/tarakbumba/xdg-su.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^xdg-su-//;s/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="${pkgdir}" install
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}