summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD34
-rwxr-xr-xxdm-arch-theme.install11
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7379f0038f2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = xdm-arch-theme
+ pkgdesc = An Arch Linux theme for xdm.
+ pkgver = 2.3.1
+ pkgrel = 3
+ url = https://github.com/the-isz/xdm-arch-theme
+ install = xdm-arch-theme.install
+ arch = any
+ license = GPL
+ makedepends = tar
+ makedepends = gzip
+ depends = xorg-xdm
+ depends = xorg-xrandr
+ depends = xorg-xclock
+ depends = xorg-xwininfo
+ depends = xorg-xsetroot
+ depends = xorg-xkill
+ depends = librsvg
+ optdepends = xorg-xmessage: for reboot/halt buttons
+ optdepends = imagemagick: one option for setting the background image
+ optdepends = feh: another option for setting the background image
+ optdepends = xv: another option for setting the background image
+ source = https://github.com/the-isz/xdm-arch-theme/tarball/2.3.1
+ source = http://upload.wikimedia.org/wikipedia/en/a/ac/Archlinux-official-fullcolour.svg
+ md5sums = 10d6a48c0cc80685273306aae7b9e03c
+ md5sums = abc1cc75e716e05a7405071d79dfdf8c
+
+pkgname = xdm-arch-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50f9d22b45ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Xappe & the_isz from archlinux.org forums
+
+pkgname=xdm-arch-theme
+pkgver=2.3.1
+pkgrel=3
+pkgdesc="An Arch Linux theme for xdm."
+arch=("any")
+url="https://github.com/the-isz/xdm-arch-theme"
+license="GPL"
+depends=("xorg-xdm" "xorg-xrandr" "xorg-xclock" "xorg-xwininfo" "xorg-xsetroot" "xorg-xkill" "librsvg")
+makedepends=("tar" "gzip")
+optdepends=(
+ "xorg-xmessage: for reboot/halt buttons"
+ "imagemagick: one option for setting the background image"
+ "feh: another option for setting the background image"
+ "xv: another option for setting the background image" )
+source=(
+ "https://github.com/the-isz/$pkgname/tarball/$pkgver"
+ "http://upload.wikimedia.org/wikipedia/en/a/ac/Archlinux-official-fullcolour.svg"
+ )
+md5sums=(
+ "10d6a48c0cc80685273306aae7b9e03c"
+ "abc1cc75e716e05a7405071d79dfdf8c"
+ )
+install=${pkgname}.install
+
+package() {
+ cd "$srcdir/the-isz-$pkgname-91ad422"
+
+ install -g root -o root -d ${pkgdir}/etc/X11/xdm/arch-xdm
+ install -g root -o root -p -m 644 arch-xdm/* ${pkgdir}/etc/X11/xdm/arch-xdm
+ chmod u+x ${pkgdir}/etc/X11/xdm/arch-xdm/buttons
+ install -g root -o root -p -m 644 ${srcdir}/Archlinux-official-fullcolour.svg ${pkgdir}/etc/X11/xdm/arch-xdm
+}
diff --git a/xdm-arch-theme.install b/xdm-arch-theme.install
new file mode 100755
index 000000000000..dd3383042d9a
--- /dev/null
+++ b/xdm-arch-theme.install
@@ -0,0 +1,11 @@
+post_install()
+{
+ echo -e "
+Remember to have your xdm point to the config file
+/etc/X11/xdm/arch-xdm/xdm-config, e.g. by using xdm's
+-config parameter.
+
+Have fun!";
+}
+
+