summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--.gitlab-ci.yml12
-rw-r--r--PKGBUILD29
-rw-r--r--hid_t_int64.patch60
5 files changed, 104 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fccaed6c95b..a7946be11dd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
-# Generated by mksrcinfo v8
-# Sat Sep 16 10:28:03 UTC 2017
pkgbase = xdmf-git
pkgdesc = eXtensible Data Model and Format
- pkgver = r2384.605db515
+ pkgver = 3.0.r2461.04a84bab
pkgrel = 1
- url = http://www.xdmf.org
+ url = https://gitlab.kitware.com/xdmf/xdmf.git
arch = i686
arch = x86_64
license = BSD
makedepends = cmake
makedepends = boost
+ makedepends = doxygen
depends = hdf5
depends = libxml2
depends = libtiff
- source = git+git://xdmf.org/Xdmf.git
+ provides = xdmf
+ conflicts = xdmf
+ source = git+https://gitlab.kitware.com/xdmf/xdmf.git
+ source = hid_t_int64.patch
sha256sums = SKIP
+ sha256sums = 41d8707c40e6e5fe3828f0427791e61bf0aee4582cf1e985884edb86cb713f01
pkgname = xdmf-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..305a6adca29f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src*/
+pkg/
+xdmf/
+*.zst
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..776bc6145d92
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,12 @@
+# You can override the included template(s) by including variable overrides
+# SAST customization: https://docs.gitlab.com/ee/user/application_security/sast/#customizing-the-sast-settings
+# Secret Detection customization: https://docs.gitlab.com/ee/user/application_security/secret_detection/#customizing-settings
+# Dependency Scanning customization: https://docs.gitlab.com/ee/user/application_security/dependency_scanning/#customizing-the-dependency-scanning-settings
+# Note that environment variables can be set in several places
+# See https://docs.gitlab.com/ee/ci/variables/#cicd-variable-precedence
+stages:
+- test
+sast:
+ stage: test
+include:
+- template: Security/SAST.gitlab-ci.yml
diff --git a/PKGBUILD b/PKGBUILD
index 550e41051aa2..dee983cf2bb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,48 @@
+# Maintainer: TiD91 <tidusuper91 at gmail dot com>
pkgname='xdmf-git'
-pkgver=r2384.605db515
+pkgver=3.0.r2461.04a84bab
pkgrel=1
pkgdesc="eXtensible Data Model and Format"
arch=('i686' 'x86_64')
-url="http://www.xdmf.org"
+url="https://gitlab.kitware.com/xdmf/xdmf.git"
license=('BSD')
depends=('hdf5' 'libxml2' 'libtiff')
-makedepends=('cmake' 'boost')
-source=("git+git://xdmf.org/Xdmf.git")
+makedepends=('cmake' 'boost' 'doxygen')
+provides=('xdmf')
+conflicts=('xdmf')
+source=("git+https://gitlab.kitware.com/xdmf/xdmf.git" "hid_t_int64.patch")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/Xdmf"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/xdmf"
+ printf "3.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd Xdmf
+ cd "$srcdir/xdmf"
+ patch --forward --strip=2 --input="${srcdir}/hid_t_int64.patch"
}
build() {
- cd Xdmf
+ cd xdmf
mkdir -p build && cd build
cmake \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DXDMF_BUILD_DOCUMENTATION=OFF\
+ -DXDMF_BUILD_TESTING=OFF \
+ -DXDMF_BUILD_UTILS=ON \
+ -DXDMF_WRAP_PYTHON=OFF \
+ -Wno-dev \
..
make
}
package() {
- cd Xdmf/build
+ cd xdmf/build
make DESTDIR="$pkgdir/" install
}
+sha256sums=('SKIP'
+ '41d8707c40e6e5fe3828f0427791e61bf0aee4582cf1e985884edb86cb713f01')
diff --git a/hid_t_int64.patch b/hid_t_int64.patch
new file mode 100644
index 000000000000..db780fc2ada9
--- /dev/null
+++ b/hid_t_int64.patch
@@ -0,0 +1,60 @@
+diff --color --unified --recursive --text src.old/xdmf/core/CMakeLists.txt src/xdmf/core/CMakeLists.txt
+--- src.old/xdmf/core/CMakeLists.txt 2022-01-10 23:22:52.940028728 +0100
++++ src/xdmf/core/CMakeLists.txt 2022-01-10 23:55:29.950022745 +0100
+@@ -29,6 +29,9 @@
+ if(HDF5_FOUND)
+ include_directories(${HDF5_INCLUDE_DIRS})
+ include_directories(${HDF5_C_INCLUDE_DIR})
++ if(HDF5_VERSION VERSION_GREATER "1.12.0")
++ set(XDMF_HID_T_64 TRUE)
++ endif()
+ # FIXME: Would like to get this info from HDF5 so we don't have conflicting
+ # MPI versions
+ if(HDF5_IS_PARALLEL)
+diff --color --unified --recursive --text src.old/xdmf/core/XdmfCoreConfig.hpp.in src/xdmf/core/XdmfCoreConfig.hpp.in
+--- src.old/xdmf/core/XdmfCoreConfig.hpp.in 2022-01-10 23:22:52.940028728 +0100
++++ src/xdmf/core/XdmfCoreConfig.hpp.in 2022-01-10 23:56:44.850022516 +0100
+@@ -29,9 +29,10 @@
+
+ #cmakedefine BUILD_SHARED
+ #ifndef BUILD_SHARED
+-# define XDMFSTATIC
++#define XDMFSTATIC
+ #endif
+
+ #cmakedefine XDMF_NO_REALPATH
++#cmakedefine XDMF_HID_T_64
+
+ #endif /* XDMFCORECONFIG_HPP_ */
+diff --color --unified --recursive --text src.old/xdmf/core/XdmfHDF5Controller.hpp src/xdmf/core/XdmfHDF5Controller.hpp
+--- src.old/xdmf/core/XdmfHDF5Controller.hpp 2022-01-10 23:22:52.940028728 +0100
++++ src/xdmf/core/XdmfHDF5Controller.hpp 2022-01-10 23:55:29.950022745 +0100
+@@ -33,7 +33,11 @@
+ #ifndef _H5Ipublic_H
+ #ifndef XDMF_HID_T
+ #define XDMF_HID_T
+- typedef int hid_t;
++ #ifndef XDMF_HID_T_64
++ typedef int hid_t;
++ #else
++ typedef int64_t hid_t;
++ #endif
+ #endif
+ #endif
+
+diff --color --unified --recursive --text src.old/xdmf/core/XdmfHDF5Writer.hpp src/xdmf/core/XdmfHDF5Writer.hpp
+--- src.old/xdmf/core/XdmfHDF5Writer.hpp 2022-01-10 23:22:52.950028728 +0100
++++ src/xdmf/core/XdmfHDF5Writer.hpp 2022-01-10 23:55:29.950022745 +0100
+@@ -34,7 +34,11 @@
+ #ifndef _H5Ipublic_H
+ #ifndef XDMF_HID_T
+ #define XDMF_HID_T
+- typedef int hid_t;
++ #ifndef XDMF_HID_T_64
++ typedef int hid_t;
++ #else
++ typedef int64_t hid_t;
++ #endif
+ #endif
+ #endif
+