summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--.nvchecker.toml4
-rw-r--r--0001-Rename-kernels.patch24
-rw-r--r--0002-Use-llvm-from-cling.patch21
-rw-r--r--0003-put-config-file-at-etc.patch8
-rw-r--r--0004-fix-build.patch47
-rw-r--r--PKGBUILD106
8 files changed, 94 insertions, 148 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a22b83c8f038..e3e23b31dc42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,30 @@
pkgbase = xeus-cling
pkgdesc = A C++ jupyter kernel based on xeus and cling
- pkgver = 0.13.0
- pkgrel = 1
+ pkgver = 0.15.3
+ pkgrel = 4
url = https://github.com/jupyter-xeus/xeus-cling
arch = x86_64
- license = BSD
+ license = BSD-3-Clause
makedepends = cmake
makedepends = cppzmq
depends = xtl
depends = xproperty
- depends = xeus
+ depends = xeus3
depends = nlohmann-json
- depends = jupyter
- depends = jupyter-widgetsnbextension
+ depends = jupyterlab
depends = cling
depends = pugixml
- depends = cxxopts
- source = https://github.com/jupyter-xeus/xeus-cling/archive/0.13.0.tar.gz
+ depends = argparse
+ depends = xeus-zmq
+ source = xeus-cling-0.15.3.tar.gz::https://github.com/jupyter-xeus/xeus-cling/archive/0.15.3.tar.gz
source = 0001-Rename-kernels.patch
source = 0002-Use-llvm-from-cling.patch
source = 0003-put-config-file-at-etc.patch
- source = 0004-fix-build.patch
- md5sums = 8d99920a167b1ca6b2ff4a3ef0bd1ded
- md5sums = e03c81c3701e4f0dea249955051c2ddf
- md5sums = 30e86ddf8e4996352eb456e12ec686bb
- md5sums = fb1bf5fdaa53af1c010b9da9d29f63b6
- md5sums = c492a7955f6bd8315fd8a100e2457744
+ source = 0004-argparse-compatibility.patch::https://github.com/jupyter-xeus/xeus-cling/pull/522.patch
+ sha512sums = bb1f3414f88d49363d65b1a8b8c2be7d9c98cdd08172c8a5f8c5490d97cd07e7d55b0ebc7f622f42838314ce20a5f3f42186df358c668f2110665f4abd008926
+ sha512sums = 4c770adb7542473b467d73c0c724ed3665f02abaef1a85aebb3a9a36f4ee6d5485cb4a429c88c863b1f53b8024e5feaa0cbdcac8f01bbc678f8a06e510e3b814
+ sha512sums = 33040a9045c8c2f100c245ff3dffe41a3185d3ca94f332256bc6cd557c61282775023400a6a044825b664181e27b1e1cda1270491de41f65657c4a69d692784d
+ sha512sums = b672c421b0efc96e93063c399f75133016dfe3c4b33bf44c089ce451394435fa59c2b562e86f6fd7c546f1a562249f0a5c48f7446312f65426533c8c39b62382
+ sha512sums = 6f03b0a41b2fe5fea4de19896316e1d8f69ca44b48551ba9070c5bfae6360d04cb78b554ab01ea4217a290433574e3f48e5b3b16fcdf1e23871acfa4b0c6e99f
pkgname = xeus-cling
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1 @@
-pkg/
-src/
-*.tar.*
+*
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..6d552c1389b3
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[xeus-cling]
+source = "github"
+github = "jupyter-xeus/xeus-cling"
+use_max_tag = true \ No newline at end of file
diff --git a/0001-Rename-kernels.patch b/0001-Rename-kernels.patch
index b00b83d5abd6..adf573920a20 100644
--- a/0001-Rename-kernels.patch
+++ b/0001-Rename-kernels.patch
@@ -1,30 +1,30 @@
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp11/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp11/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp11/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp11/kernel.json.in 2020-09-23 17:42:44.849674536 +0200
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp11/kernel.json.in xeus-cling-0.15.2/share/jupyter/kernels/xcpp11/kernel.json.in
+--- ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp11/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/share/jupyter/kernels/xcpp11/kernel.json.in 2023-07-21 22:06:15.136418009 -0500
@@ -1,5 +1,5 @@
{
- "display_name": "C++11",
+ "display_name": "C++11 (xeus)",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp14/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp14/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp14/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp14/kernel.json.in 2020-09-23 17:42:54.722971891 +0200
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp14/kernel.json.in xeus-cling-0.15.2/share/jupyter/kernels/xcpp14/kernel.json.in
+--- ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp14/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/share/jupyter/kernels/xcpp14/kernel.json.in 2023-07-21 22:06:22.840027031 -0500
@@ -1,5 +1,5 @@
{
- "display_name": "C++14",
+ "display_name": "C++14 (xeus)",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
-diff --unified --recursive --text xeus-cling-0.10.0/share/jupyter/kernels/xcpp17/kernel.json.in xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp17/kernel.json.in
---- xeus-cling-0.10.0/share/jupyter/kernels/xcpp17/kernel.json.in 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/share/jupyter/kernels/xcpp17/kernel.json.in 2020-09-23 17:43:03.549606392 +0200
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp17/kernel.json.in xeus-cling-0.15.2/share/jupyter/kernels/xcpp17/kernel.json.in
+--- ../xeus-cling-0.15.2-fixed/share/jupyter/kernels/xcpp17/kernel.json.in 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/share/jupyter/kernels/xcpp17/kernel.json.in 2023-07-21 22:06:30.293625078 -0500
@@ -1,5 +1,5 @@
{
- "display_name": "C++17",
+ "display_name": "C++17 (xeus)",
"argv": [
- "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/xcpp",
+ "@XEUS_CLING_KERNELSPEC_PATH@/xcpp",
"-f",
diff --git a/0002-Use-llvm-from-cling.patch b/0002-Use-llvm-from-cling.patch
index d23a03be7294..b463fd81bc12 100644
--- a/0002-Use-llvm-from-cling.patch
+++ b/0002-Use-llvm-from-cling.patch
@@ -1,7 +1,7 @@
-diff --unified --recursive --text xeus-cling-0.10.0/CMakeLists.txt xeus-cling-0.10.0-fixed/CMakeLists.txt
---- xeus-cling-0.10.0/CMakeLists.txt 2020-08-29 00:08:47.000000000 +0200
-+++ xeus-cling-0.10.0-fixed/CMakeLists.txt 2020-09-23 17:00:45.525608638 +0200
-@@ -46,58 +46,6 @@
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/CMakeLists.txt xeus-cling-0.15.2/CMakeLists.txt
+--- ../xeus-cling-0.15.2-fixed/CMakeLists.txt 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/CMakeLists.txt 2023-07-21 21:05:07.308285729 -0500
+@@ -50,59 +50,6 @@
"${CMAKE_CURRENT_SOURCE_DIR}/share/jupyter/kernels/xcpp17/kernel.json"
)
@@ -57,11 +57,12 @@ diff --unified --recursive --text xeus-cling-0.10.0/CMakeLists.txt xeus-cling-0.
-include_directories(${LLVM_MAIN_INCLUDE_DIR})
-link_directories(${LLVM_LIBRARY_DIR})
-add_definitions(-DLLVM_DIR="${LLVM_BINARY_DIR}")
-
+-
################
# Dependencies #
-@@ -110,8 +58,10 @@
- find_package(cppzmq ${cppzmq_REQUIRED_VERSION} REQUIRED)
+ ################
+@@ -112,8 +59,10 @@
+ find_package(xeus-zmq ${xeus-zmq_REQUIRED_VERSION} REQUIRED)
find_package(pugixml REQUIRED)
-find_package(Clang REQUIRED)
@@ -69,14 +70,14 @@ diff --unified --recursive --text xeus-cling-0.10.0/CMakeLists.txt xeus-cling-0.
+find_package(Clang REQUIRED)
+find_package(LLVM REQUIRED)
+add_definitions(-DLLVM_DIR="${LLVM_INSTALL_PREFIX}")
- find_package(cxxopts REQUIRED)
+ find_package(argparse REQUIRED)
#########
-@@ -228,6 +178,7 @@
+@@ -219,6 +168,7 @@
target_include_directories(xeus-cling
PUBLIC
+ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
$<BUILD_INTERFACE:${XEUS_CLING_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include>)
- target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus pugixml cxxopts::cxxopts)
+ target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus-zmq pugixml argparse::argparse)
diff --git a/0003-put-config-file-at-etc.patch b/0003-put-config-file-at-etc.patch
index 4f4b09a89baf..cb15a306d621 100644
--- a/0003-put-config-file-at-etc.patch
+++ b/0003-put-config-file-at-etc.patch
@@ -1,7 +1,7 @@
-diff --unified --recursive --text xeus-cling-0.12.1/CMakeLists.txt xeus-cling-0.12.1-fixed/CMakeLists.txt
---- xeus-cling-0.12.1/CMakeLists.txt 2021-03-16 22:48:10.000000000 +0800
-+++ xeus-cling-0.12.1-fixed/CMakeLists.txt 2021-04-23 08:48:47.772221440 +0800
-@@ -371,7 +371,7 @@
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/CMakeLists.txt xeus-cling-0.15.2/CMakeLists.txt
+--- ../xeus-cling-0.15.2-fixed/CMakeLists.txt 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/CMakeLists.txt 2023-07-21 20:58:34.801675991 -0500
+@@ -364,7 +364,7 @@
# Configuration and data directories for jupyter and xeus-cling
set(XJUPYTER_DATA_DIR "share/jupyter" CACHE STRING "Jupyter data directory")
set(XEUS_CLING_DATA_DIR "share/xeus-cling" CACHE STRING "xeus-cling data directory")
diff --git a/0004-fix-build.patch b/0004-fix-build.patch
deleted file mode 100644
index 922bfdc1f725..000000000000
--- a/0004-fix-build.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-# from https://github.com/jupyter-xeus/xeus-cling/issues/400
-diff -Naur xeus-cling-0.12.1.orig/src/xmagics/executable.cpp xeus-cling-0.12.1/src/xmagics/executable.cpp
---- xeus-cling-0.12.1.orig/src/xmagics/executable.cpp 2021-03-16 14:48:10.000000000 +0000
-+++ xeus-cling-0.12.1/src/xmagics/executable.cpp 2021-04-29 12:10:03.955599380 +0000
-@@ -131,7 +131,7 @@
-
- // Generate relocations suitable for dynamic linking.
- auto CodeGenOpts = CI->getCodeGenOpts();
-- CodeGenOpts.RelocationModel = "pic";
-+ CodeGenOpts.RelocationModel = llvm::Reloc::PIC_;
-
- // Enable debug information if requested.
- if (EnableDebugInfo)
-@@ -187,7 +187,7 @@
- llvm::sys::path::append(Compiler, "bin", "clang++");
-
- // Construct arguments to linker command.
-- llvm::SmallVector<const char*, 16> Args;
-+ llvm::SmallVector<llvm::StringRef, 16> Args;
- Args.push_back(Compiler.c_str());
- Args.push_back(ObjectFile.c_str());
- for (auto& O : LinkerOptions)
-@@ -196,7 +196,7 @@
- }
- Args.push_back("-o");
- Args.push_back(ExeFile.c_str());
-- Args.push_back(NULL);
-+ // Args.push_back(NULL);
-
- // Redirect output and error streams from linker.
- llvm::SmallString<64> OutputFile, ErrorFile;
-@@ -207,11 +207,11 @@
-
- llvm::StringRef OutputFileStr(OutputFile);
- llvm::StringRef ErrorFileStr(ErrorFile);
-- const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
-- &ErrorFileStr};
--
-+ //const llvm::StringRef* Redirects[] = {nullptr, &OutputFileStr,
-+ // &ErrorFileStr};
-+ const clang::Optional<llvm::StringRef> Redirects[] = {llvm::NoneType::None, OutputFileStr, ErrorFileStr};
- // Finally run the linker.
-- int ret = llvm::sys::ExecuteAndWait(Compiler, Args.data(), nullptr,
-+ int ret = llvm::sys::ExecuteAndWait(Compiler, Args, llvm::NoneType::None,
- Redirects);
-
- // Read back output and error streams. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 11c5e568327a..1d48f7a70765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,59 @@
-# Maintainer: Sebastian Gsänger <sebastian_gsaenger@web.de>
-# Maintainer: chn <g897331845@gmail.com>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Sebastian Gsänger <sebastian_gsaenger@web.de>
+# Contributor: chn <g897331845@gmail.com>
+# Contributor: Gregor Kaelin <kaelingre at gmail dot com>
pkgname=xeus-cling
-pkgver=0.13.0
-pkgrel=2
+pkgver=0.15.3
+pkgrel=4
pkgdesc="A C++ jupyter kernel based on xeus and cling"
-arch=('x86_64')
-url="https://github.com/jupyter-xeus/xeus-cling"
-license=('BSD')
-depends=('xtl' 'xproperty' 'xeus' 'nlohmann-json'
- 'jupyter-notebook' 'jupyter-widgetsnbextension'
- 'cling' 'pugixml' 'cxxopts')
-makedepends=('cmake' 'cppzmq')
-source=("https://github.com/jupyter-xeus/$pkgname/archive/$pkgver.tar.gz"
- "0001-Rename-kernels.patch"
- "0002-Use-llvm-from-cling.patch"
- "0003-put-config-file-at-etc.patch"
- "0004-fix-build.patch")
-md5sums=('8d99920a167b1ca6b2ff4a3ef0bd1ded'
- 'e03c81c3701e4f0dea249955051c2ddf'
- '30e86ddf8e4996352eb456e12ec686bb'
- 'fb1bf5fdaa53af1c010b9da9d29f63b6'
- 'c492a7955f6bd8315fd8a100e2457744')
+arch=(x86_64)
+url="https://github.com/jupyter-xeus/${pkgname}"
+license=(BSD-3-Clause)
+depends=(xtl xproperty xeus3 nlohmann-json jupyterlab cling pugixml argparse xeus-zmq)
+makedepends=(cmake cppzmq)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+ "0001-Rename-kernels.patch"
+ "0002-Use-llvm-from-cling.patch"
+ "0003-put-config-file-at-etc.patch"
+ "0004-argparse-compatibility.patch::${url}/pull/522.patch")
+sha512sums=('bb1f3414f88d49363d65b1a8b8c2be7d9c98cdd08172c8a5f8c5490d97cd07e7d55b0ebc7f622f42838314ce20a5f3f42186df358c668f2110665f4abd008926'
+ '4c770adb7542473b467d73c0c724ed3665f02abaef1a85aebb3a9a36f4ee6d5485cb4a429c88c863b1f53b8024e5feaa0cbdcac8f01bbc678f8a06e510e3b814'
+ '33040a9045c8c2f100c245ff3dffe41a3185d3ca94f332256bc6cd557c61282775023400a6a044825b664181e27b1e1cda1270491de41f65657c4a69d692784d'
+ 'b672c421b0efc96e93063c399f75133016dfe3c4b33bf44c089ce451394435fa59c2b562e86f6fd7c546f1a562249f0a5c48f7446312f65426533c8c39b62382'
+ '6f03b0a41b2fe5fea4de19896316e1d8f69ca44b48551ba9070c5bfae6360d04cb78b554ab01ea4217a290433574e3f48e5b3b16fcdf1e23871acfa4b0c6e99f')
prepare() {
- cd "$pkgname-$pkgver"
-
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ cd ${pkgname}-${pkgver}
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 <"../$src"
+ done
}
build() {
-
- if [ -z $CPLUS_INCLUDE_PATH ]
- then
- export CPLUS_INCLUDE_PATH=/opt/cling/include
- else
- export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/opt/cling/include
- fi
-
- cd "$pkgname-$pkgver"
- mkdir -p build
- cd build
-
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DClang_DIR=/opt/cling/lib/cmake/clang \
- ..
-
- cmake --build .
+ if [ -z $CPLUS_INCLUDE_PATH ]; then
+ export CPLUS_INCLUDE_PATH=/opt/cling/include
+ else
+ export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/opt/cling/include
+ fi
+
+ cmake \
+ -S ${pkgname}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=TRUE \
+ -DCMAKE_CXX_STANDARD=17 \
+ -DClang_DIR=/opt/cling/lib/cmake/clang
+ cmake --build build --target all
}
package() {
- cd "$pkgname-$pkgver"
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd "build"
-
- DESTDIR="$pkgdir" cmake --build . -t install
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${pkgname}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}