summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--14393-gestures-only.patch73
-rw-r--r--50-synaptics.conf.patch15
-rw-r--r--PKGBUILD11
4 files changed, 27 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c681c8a9e2f1..4014d3d7fe5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Jan 18 16:33:16 UTC 2017
pkgbase = xf86-input-synaptics-gesturesonly
pkgdesc = Synaptics driver for notebook touchpads
- pkgver = 1.8.2
+ pkgver = 1.9.0
pkgrel = 1
url = http://patchwork.freedesktop.org/patch/14393/
arch = i686
@@ -18,15 +20,12 @@ pkgbase = xf86-input-synaptics-gesturesonly
conflicts = synaptics
options = !libtool
options = zipman
- source = xf86-input-synaptics::git://anongit.freedesktop.org/xorg/driver/xf86-input-synaptics#tag=xf86-input-synaptics-1.8.2
- source = 50-synaptics.conf.patch
+ source = xf86-input-synaptics::git://anongit.freedesktop.org/xorg/driver/xf86-input-synaptics#tag=xf86-input-synaptics-1.9.0
source = 14393-gestures-only.patch
md5sums = SKIP
- md5sums = 5ae00aad3e70265defa5bd08da621b5c
- md5sums = 21afe2219d3bf9a628bbae1e4922978e
+ md5sums = 8639335e76a1dd50f77ace9fc8fe0975
sha256sums = SKIP
- sha256sums = 8c24a04508acfab32b78e8dfbebe589e35f908cc74f1225215eed6fd48c530c3
- sha256sums = 781ed57c18b55c3826f5b3be7c966c6d6dadf2234b9e42fb1052150c987172be
+ sha256sums = fb08b1b9a3f565e0559587e4dc9450c740279c727f57aff9d571e303c1911892
pkgname = xf86-input-synaptics-gesturesonly
diff --git a/14393-gestures-only.patch b/14393-gestures-only.patch
index 8a9bcf85c2cb..89c0372243a8 100644
--- a/14393-gestures-only.patch
+++ b/14393-gestures-only.patch
@@ -1,44 +1,5 @@
-diff --git a/conf/50-synaptics.conf b/conf/50-synaptics.conf
-index aa50456..6c9c7d7 100644
---- a/conf/50-synaptics.conf
-+++ b/conf/50-synaptics.conf
-@@ -15,6 +15,34 @@ Section "InputClass"
- # enabled by default. See the following link for details:
- # http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
- # MatchDevicePath "/dev/input/event*"
-+
-+# Uncomment as desired:
-+# Option "TapButton1" "1"
-+# Option "TapButton2" "3"
-+# Option "TapButton3" "2"
-+# Option "VertEdgeScroll" "on"
-+# Option "VertTwoFingerScroll" "on"
-+# Option "HorizEdgeScroll" "on"
-+# Option "HorizTwoFingerScroll" "on"
-+# Option "CircularScrolling" "on"
-+# Option "CircScrollTrigger" "2"
-+# Option "EmulateTwoFingerMinZ" "40"
-+# Option "EmulateTwoFingerMinW" "8"
-+# Option "CoastingSpeed" "0"
-+
-+# Uncomment as desired:
-+# Option "TapButton1" "1"
-+# Option "TapButton2" "3"
-+# Option "TapButton3" "2"
-+# Option "VertEdgeScroll" "on"
-+# Option "VertTwoFingerScroll" "on"
-+# Option "HorizEdgeScroll" "on"
-+# Option "HorizTwoFingerScroll" "on"
-+# Option "CircularScrolling" "on"
-+# Option "CircScrollTrigger" "2"
-+# Option "EmulateTwoFingerMinZ" "40"
-+# Option "EmulateTwoFingerMinW" "8"
-+# Option "CoastingSpeed" "0"
- EndSection
-
- Section "InputClass"
diff --git a/include/synaptics-properties.h b/include/synaptics-properties.h
-index 32ab2e1..91d8160 100644
+index 0f79b64..d74dc2e 100644
--- a/include/synaptics-properties.h
+++ b/include/synaptics-properties.h
@@ -158,4 +158,7 @@
@@ -50,7 +11,7 @@ index 32ab2e1..91d8160 100644
+
#endif /* _SYNAPTICS_PROPERTIES_H_ */
diff --git a/man/synaptics.man b/man/synaptics.man
-index 76756be..71ef3ea 100644
+index 4f87b01..1b00e42 100644
--- a/man/synaptics.man
+++ b/man/synaptics.man
@@ -518,6 +518,15 @@ initialized if
@@ -69,19 +30,19 @@ index 76756be..71ef3ea 100644
.SH CONFIGURATION DETAILS
.SS Area handling
-@@ -907,6 +916,10 @@ disables the button area.
+@@ -905,6 +914,10 @@ disables the button area.
+
32 bit, 8 values, RBL, RBR, RBT, RBB, MBL, MBR, MBT, MBB.
- .TP 7
++.TP 7
+.BI "Synaptics Gestures Only"
+8 bit (BOOL).
+
-+.TP 7
+ .TP 7
.BI "Synaptics Capabilities"
This read-only property expresses the physical capability of the touchpad,
- most notably whether the touchpad hardware supports multi-finger tapping and
diff --git a/src/properties.c b/src/properties.c
-index 718d054..6e376f9 100644
+index c776e6c..05c3c2b 100644
--- a/src/properties.c
+++ b/src/properties.c
@@ -95,6 +95,7 @@ Atom prop_secondary_softbutton_areas = 0;
@@ -92,7 +53,7 @@ index 718d054..6e376f9 100644
static Atom
InitTypedAtom(DeviceIntPtr dev, char *name, Atom type, int format, int nvalues,
-@@ -381,6 +382,10 @@ InitDeviceProperties(InputInfoPtr pInfo)
+@@ -382,6 +383,10 @@ InitDeviceProperties(InputInfoPtr pInfo)
SYNAPTICS_PROP_NOISE_CANCELLATION, 32, 2,
values);
@@ -103,7 +64,7 @@ index 718d054..6e376f9 100644
/* only init product_id property if we actually know them */
if (priv->id_vendor || priv->id_product) {
values[0] = priv->id_vendor;
-@@ -814,6 +819,12 @@ SetProperty(DeviceIntPtr dev, Atom property, XIPropertyValuePtr prop,
+@@ -815,6 +820,12 @@ SetProperty(DeviceIntPtr dev, Atom property, XIPropertyValuePtr prop,
para->hyst_x = hyst[0];
para->hyst_y = hyst[1];
}
@@ -117,18 +78,18 @@ index 718d054..6e376f9 100644
return BadValue; /* read-only */
else { /* unknown property */
diff --git a/src/synaptics.c b/src/synaptics.c
-index 2d49a12..168bdba 100644
+index c7ba9ad..f67e470 100644
--- a/src/synaptics.c
+++ b/src/synaptics.c
@@ -673,6 +673,7 @@ set_default_parameters(InputInfoPtr pInfo)
pars->tap_move = xf86SetIntOption(opts, "MaxTapMove", tapMove);
- pars->tap_time_2 = xf86SetIntOption(opts, "MaxDoubleTapTime", 100);
+ pars->tap_time_2 = xf86SetIntOption(opts, "MaxDoubleTapTime", 180);
pars->click_time = xf86SetIntOption(opts, "ClickTime", 100);
+ pars->gestures_only = xf86SetBoolOption(opts, "GesturesOnly", pars->gestures_only);
pars->clickpad = xf86SetBoolOption(opts, "ClickPad", pars->clickpad); /* Probed */
if (pars->clickpad)
pars->has_secondary_buttons = xf86SetBoolOption(opts,
-@@ -3207,7 +3208,7 @@ HandleState(InputInfoPtr pInfo, struct SynapticsHwState *hw, CARD32 now,
+@@ -3138,7 +3139,7 @@ HandleState(InputInfoPtr pInfo, struct SynapticsHwState *hw, CARD32 now,
buttons |= 1 << (priv->tap_button - 1);
/* Post events */
@@ -138,14 +99,14 @@ index 2d49a12..168bdba 100644
if (priv->mid_emu_state == MBE_LEFT_CLICK) {
diff --git a/src/synapticsstr.h b/src/synapticsstr.h
-index 8917991..4181407 100644
+index 33524e5..b23ec3c 100644
--- a/src/synapticsstr.h
+++ b/src/synapticsstr.h
-@@ -225,6 +225,7 @@ typedef struct _SynapticsParameters {
+@@ -229,6 +229,7 @@ typedef struct _SynapticsParameters {
int area_left_edge, area_right_edge, area_top_edge, area_bottom_edge; /* area coordinates absolute */
int softbutton_areas[4][4]; /* soft button area coordinates, 0 => right, 1 => middle , 2 => secondary right, 3 => secondary middle button */
int hyst_x, hyst_y; /* x and y width of hysteresis box */
-+ Bool gestures_only; /* do not post mouse input events */
- } SynapticsParameters;
++ Bool gestures_only; /* do not post mouse input events */
- struct _SynapticsPrivateRec {
+ int maxDeltaMM; /* maximum delta movement (vector length) in mm */
+ } SynapticsParameters;
diff --git a/50-synaptics.conf.patch b/50-synaptics.conf.patch
deleted file mode 100644
index 64df6064229d..000000000000
--- a/50-synaptics.conf.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-17a18,31
->
-> # Uncomment as desired:
-> # Option "TapButton1" "1"
-> # Option "TapButton2" "3"
-> # Option "TapButton3" "2"
-> # Option "VertEdgeScroll" "on"
-> # Option "VertTwoFingerScroll" "on"
-> # Option "HorizEdgeScroll" "on"
-> # Option "HorizTwoFingerScroll" "on"
-> # Option "CircularScrolling" "on"
-> # Option "CircScrollTrigger" "2"
-> # Option "EmulateTwoFingerMinZ" "40"
-> # Option "EmulateTwoFingerMinW" "8"
-> # Option "CoastingSpeed" "0"
diff --git a/PKGBUILD b/PKGBUILD
index dcd3e6bd3ad0..a0623da414cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xf86-input-synaptics-gesturesonly
_pkgname=xf86-input-synaptics
-pkgver=1.8.3
+pkgver=1.9.0
pkgrel=1
pkgdesc="Synaptics driver for notebook touchpads"
arch=('i686' 'x86_64')
@@ -17,14 +17,12 @@ conflicts=('synaptics')
groups=('xorg-input-drivers')
options=('!libtool' 'zipman')
source=("$_pkgname"::"git://anongit.freedesktop.org/xorg/driver/xf86-input-synaptics#tag=$_pkgname-$pkgver"
- '50-synaptics.conf.patch'
'14393-gestures-only.patch')
md5sums=('SKIP'
- '5ae00aad3e70265defa5bd08da621b5c'
- '21afe2219d3bf9a628bbae1e4922978e')
+ '8639335e76a1dd50f77ace9fc8fe0975')
sha256sums=('SKIP'
- '8c24a04508acfab32b78e8dfbebe589e35f908cc74f1225215eed6fd48c530c3'
- '781ed57c18b55c3826f5b3be7c966c6d6dadf2234b9e42fb1052150c987172be')
+ 'fb08b1b9a3f565e0559587e4dc9450c740279c727f57aff9d571e303c1911892')
+
prepare() {
cd "$srcdir/$_pkgname"
@@ -38,7 +36,6 @@ build() {
./autogen.sh
./configure --prefix=/usr --with-xorg-conf-dir=/etc/X11/xorg.conf.d
make
- patch conf/50-synaptics.conf < $srcdir/50-synaptics.conf.patch
}
package() {
cd "$srcdir/$_pkgname"