summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd02dcbcafe0..f9e3eda34d73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = xf86-input-xwiimote-git
pkgdesc = X.Org Nintendo Wii Remote input driver
pkgver = 0.5.r0.gbb1528d
pkgrel = 1
- url = http://github.com/dvdhrm/xf86-input-xwiimote
+ url = https://github.com/dvdhrm/xf86-input-xwiimote
arch = i686
arch = x86_64
license = MIT
@@ -12,8 +12,7 @@ pkgbase = xf86-input-xwiimote-git
conflicts = xorg-server<1.10.99.902
conflicts = xf86-input-xwiimote
options = !libtool
- source = git://github.com/dvdhrm/xf86-input-xwiimote.git
+ source = https://github.com/dvdhrm/xf86-input-xwiimote.git
sha512sums = SKIP
pkgname = xf86-input-xwiimote-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f05f93e29ee..2f494b5da7ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: David Manouchehri <d@32t.ca>
+# Maintainer: Kai <kaibbusinessinq@gmail.com>
+# Contributor: David Manouchehri <d@32t.ca>
pkgname=xf86-input-xwiimote-git
_gitname=xf86-input-xwiimote
@@ -7,31 +8,29 @@ pkgver=0.5.r0.gbb1528d
pkgrel=1
pkgdesc='X.Org Nintendo Wii Remote input driver'
arch=('i686' 'x86_64')
-url="http://github.com/$_gitauthor/$_gitname"
+url="https://github.com/$_gitauthor/$_gitname"
license=('MIT')
depends=('xwiimote' 'udev')
makedepends=('xorg-server-devel>=1.10.99.902')
conflicts=('xorg-server<1.10.99.902' 'xf86-input-xwiimote')
providers=('xf86-input-xwiimote')
options=(!libtool)
-source=("git://github.com/$_gitauthor/$_gitname.git")
+source=("https://github.com/$_gitauthor/$_gitname.git")
sha512sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_gitname"
- git describe --long | sed -E 's/xf86-input-xwiimote-//;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
build() {
+ mkdir -p "$srcdir/$_gitname"
cd "$srcdir/$_gitname"
- mkdir "$srcdir/$_gitname/m4"
- autoreconf -i || exit 1
+ mkdir -p "$srcdir/$_gitname/m4"
+ git clone https://github.com/dvdhrm/xf86-input-xwiimote m4
+ autoreconf -i $srcdir/$_gitname/m4 || exit 1 ##normal to get a warning
+ cd "$srcdir/$_gitname/m4"
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_gitname/m4"
mkdir -p "$pkgdir/usr/share/licenses/$_gitname"
cp COPYING "$pkgdir/usr/share/licenses/$_gitname"
mkdir -p "$pkgdir/etc/X11/xorg.conf.d/"