summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 28 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1f305ec6646..eb5db09a560a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
-# Generated by mksrcinfo v8
-# Sun Aug 7 12:01:47 UTC 2016
pkgbase = xfce-theme-manager
pkgdesc = A theme manager allowing easy configuration of themes, window borders, controls, icons and cursors for Xfce.
- pkgver = 0.3.7
- pkgrel = 2
- url = http://khapplications.darktech.org/pages/apps.html#themeed
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = https://github.com/KeithDHedger/Xfce-Theme-Manager
arch = i686
arch = x86_64
license = GPL3
makedepends = pkg-config
- makedepends = make
- makedepends = autoconf
depends = gdk-pixbuf2
depends = cairo
depends = libxcursor
depends = libxfce4ui
optdepends = xfce4-composite-editor: A simple GUI to tweak xfwm, can be launched from xfce-theme-manager
- source = https://dl.dropboxusercontent.com/s/bh16k3am8q7zvat/Xfce-Theme-Manager-0.3.7.tar.gz
- sha256sums = 5cb5970cb08bdf76a1ae326d974f1d504e3c94e04a2737ecfa7703fe96e47f53
+ source = https://github.com/KeithDHedger/Xfce-Theme-Manager/archive/xfce-theme-manager-0.3.8.tar.gz
+ sha256sums = 110eea06a36096c0fc8bf2dd9fe03c90e066f42aebd91f71f1159e87dff99b6f
pkgname = xfce-theme-manager
diff --git a/PKGBUILD b/PKGBUILD
index d5ad67c39873..bcc38b67c460 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
# Contributor: Martin F. Schumann <mfs at mfs dot name>
pkgname=xfce-theme-manager
_pkgname=Xfce-Theme-Manager
-pkgver=0.3.7
-pkgrel=2
+pkgver=0.3.8
+pkgrel=1
pkgdesc="A theme manager allowing easy configuration of themes, window borders, controls, icons and cursors for Xfce."
-arch=('i686' 'x86_64')
-url="http://khapplications.darktech.org/pages/apps.html#themeed"
-license=("GPL3")
-depends=('gdk-pixbuf2' 'cairo' 'libxcursor' 'libxfce4ui')
+arch=(i686 x86_64)
+url="https://github.com/KeithDHedger/Xfce-Theme-Manager"
+license=(GPL3)
+depends=(gdk-pixbuf2 cairo libxcursor libxfce4ui)
optdepends=('xfce4-composite-editor: A simple GUI to tweak xfwm, can be launched from xfce-theme-manager')
-makedepends=('pkg-config' 'make' 'autoconf')
-source=("https://dl.dropboxusercontent.com/s/bh16k3am8q7zvat/$_pkgname-${pkgver}.tar.gz")
-sha256sums=('5cb5970cb08bdf76a1ae326d974f1d504e3c94e04a2737ecfa7703fe96e47f53')
+makedepends=(pkg-config)
+source=("https://github.com/KeithDHedger/$_pkgname/archive/$pkgname-${pkgver}.tar.gz")
+sha256sums=('110eea06a36096c0fc8bf2dd9fe03c90e066f42aebd91f71f1159e87dff99b6f')
build() {
- cd "$srcdir"/$_pkgname-$pkgver
+ cd "$srcdir"/$_pkgname-$pkgname-$pkgver
./autogen.sh --prefix="$pkgdir"/usr
+ sed -i \
+ 's#/PREFIX/share/Xfce\\-Theme\\-Manager/scripts#/usr/share/xfce\\-theme\\-manager/scripts#g' \
+ "$srcdir"/$_pkgname-$pkgname-$pkgver/$_pkgname/resources/man/*
+ sed -i \
+ 's/Name=Xfce-Theme-Manager/Name=Xfce Theme Manager/g;s/^Comment.*/Comment=Control Xfce4 Themes, Icons, Cursors, Wallpapers and more/g' \
+ $_pkgname/resources/pixmaps/$_pkgname.desktop
}
package() {
- install -m 755 -d "$pkgdir"/usr/bin "$pkgdir"/usr/share/applications "$pkgdir"/usr/share/doc/xfce-theme-manager
- sed -i 's#/PREFIX/share/Xfce\\-Theme\\-Manager/scripts#/usr/share/xfce\\-theme\\-manager/scripts#g' "$srcdir"/$_pkgname-$pkgver/$_pkgname/resources/man/*
- cd "$srcdir"/$_pkgname-$pkgver
- sed -i 's/Name=Xfce-Theme-Manager/Name=Xfce Theme Manager/g;s/^Comment.*/Comment=Control Xfce4 Themes, Icons, Cursors, Wallpapers and more/g' $_pkgname/resources/pixmaps/$_pkgname.desktop
+ install -m 755 -d "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/applications \
+ "$pkgdir"/usr/share/doc/xfce-theme-manager
+
+ cd "$srcdir"/$_pkgname-$pkgname-$pkgver
make CXXFLAGS="$CXXFLAGS -O3 -Wall `pkg-config --cflags --libs glib-2.0` `pkg-config --cflags --libs gdk-2.0` `pkg-config --cflags --libs gtk+-2.0` `pkg-config --cflags --libs xcursor` `pkg-config --cflags --libs gthread-2.0`" PREFIX="$pkgdir/usr" install
+
install -m 644 README* "$pkgdir"/usr/share/doc/$pkgname/
install -m 644 ChangeLog* "$pkgdir"/usr/share/doc/$pkgname/
mv "$pkgdir"/usr/share/{$_pkgname,$pkgname}