summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--xfce4-appfinder.install13
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d8291d0a9ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfce4-appfinder-devel
+ pkgdesc = An application finder for Xfce
+ pkgver = 4.11.0
+ pkgrel = 1
+ url = http://www.xfce.org/
+ install = xfce4-appfinder.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ depends = libxfce4ui>=4.11
+ depends = garcon>=0.3.0
+ depends = hicolor-icon-theme
+ provides = xfce4-appfinder=4.11.0
+ conflicts = xfce4-appfinder
+ replaces = xfce-utils
+ source = http://archive.xfce.org/src/xfce/xfce4-appfinder/4.11/xfce4-appfinder-4.11.0.tar.bz2
+ sha256sums = 49bfe38623b5a6e65b8a654d353f439e6dcf981aaf831fe2e31d59dacd95c618
+
+pkgname = xfce4-appfinder-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80dac74646ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=xfce4-appfinder
+pkgname=${_pkgname}-devel
+pkgver=4.11.0
+pkgrel=1
+pkgdesc="An application finder for Xfce"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+depends=('libxfce4ui>=4.11' 'garcon>=0.3.0' 'hicolor-icon-theme')
+makedepends=('intltool')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+replaces=('xfce-utils')
+install=$_pkgname.install
+source=(http://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2)
+sha256sums=('49bfe38623b5a6e65b8a654d353f439e6dcf981aaf831fe2e31d59dacd95c618')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-appfinder.install b/xfce4-appfinder.install
new file mode 100644
index 000000000000..e4f8fd06c1ed
--- /dev/null
+++ b/xfce4-appfinder.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: