summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9727fa025bb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 27 18:31:42 UTC 2017
+pkgbase = xfce4-genmon-plugin-gtk2
+ pkgdesc = Plugin that monitors customizable programs stdout for the Xfce4 panel (GTK2 version)
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = LGPL2.1
+ makedepends = intltool
+ depends = xfce4-panel
+ provides = xfce4-genmon-plugin
+ conflicts = xfce4-genmon-plugin
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-genmon-plugin/3.4/xfce4-genmon-plugin-3.4.0.tar.bz2
+ sha256sums = b0a5337b49c85623dc89f3c9e47c7374b1d466af2418033d2d6dfc57a9790387
+
+pkgname = xfce4-genmon-plugin-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80676c7ea750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Tobias Kieslich <tobias (at) archlinux.org>
+
+_pkgname=xfce4-genmon-plugin
+pkgname=${_pkgname}-gtk2
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="Plugin that monitors customizable programs stdout for the Xfce4 panel (GTK2 version)"
+arch=('i686' 'x86_64')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+license=('LGPL2.1')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin"
+groups=('xfce4-goodies')
+depends=('xfce4-panel')
+makedepends=('intltool')
+source=(http://archive.xfce.org/src/panel-plugins/$_pkgname/3.4/$_pkgname-$pkgver.tar.bz2)
+sha256sums=('b0a5337b49c85623dc89f3c9e47c7374b1d466af2418033d2d6dfc57a9790387')
+
+build() {
+ cd "$srcdir/$_pkgname-3.4"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-3.4"
+ make DESTDIR="$pkgdir" install
+}