summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 23 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19c75d2c4494..e9a8a5d84dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,19 @@
-# Generated by mksrcinfo v8
-# Tue Mar 13 08:46:17 UTC 2018
pkgbase = xfce4-indicator-plugin
pkgdesc = Plugin to display information from applications in the Xfce4 panel
- pkgver = 2.3.4
+ pkgver = 2.4.1
pkgrel = 1
- url = http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin
- install = xfce4-indicator-plugin.install
+ url = https://docs.xfce.org/panel-plugins/xfce4-indicator-plugin/start
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = GPL
makedepends = intltool
- makedepends = xfce4-dev-tools
depends = hicolor-icon-theme
- depends = ido
- depends = libindicator-gtk2
depends = libindicator-gtk3
depends = xfce4-panel
depends = xdg-utils
- optdepends = indicator-application-gtk2: take menus from applications and place them in the panel
- optdepends = indicator-sound: unified sound menu
- source = http://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/2.3/xfce4-indicator-plugin-2.3.4.tar.bz2
- sha256sums = 02773722cf99113bc64cc399df47c3a639e206a864c6995be68fe8281076582e
+ source = https://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/2.4/xfce4-indicator-plugin-2.4.1.tar.bz2
+ sha256sums = 926af0930417ebb45f3acc71b6bee66cc21593c79ec0ca9e8782147e6c50f020
pkgname = xfce4-indicator-plugin
-
diff --git a/PKGBUILD b/PKGBUILD
index 46e6326c28cf..fe5df27e5b80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,29 @@
-# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=xfce4-indicator-plugin
-_maj=2.3
-pkgver=$_maj.4
+pkgver=2.4.1
pkgrel=1
pkgdesc="Plugin to display information from applications in the Xfce4 panel"
-arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/panel-plugins/$pkgname"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url='https://docs.xfce.org/panel-plugins/xfce4-indicator-plugin/start'
license=('GPL')
-depends=('hicolor-icon-theme'
- 'ido'
- 'libindicator-gtk2'
- 'libindicator-gtk3'
- 'xfce4-panel'
- 'xdg-utils')
-makedepends=('intltool' 'xfce4-dev-tools')
-optdepends=('indicator-application-gtk2: take menus from applications and place them in the panel'
- 'indicator-sound: unified sound menu')
-install=$pkgname.install
-source=(http://archive.xfce.org/src/panel-plugins/$pkgname/$_maj/$pkgname-$pkgver.tar.bz2)
-sha256sums=('02773722cf99113bc64cc399df47c3a639e206a864c6995be68fe8281076582e')
+depends=('hicolor-icon-theme' 'libindicator-gtk3' 'xfce4-panel' 'xdg-utils')
+makedepends=('intltool')
+source=(https://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('926af0930417ebb45f3acc71b6bee66cc21593c79ec0ca9e8782147e6c50f020')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --disable-static
make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
}