summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO20
-rwxr-xr-xPKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..f34358580c23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xfce4-nameday-plugin-git
+ pkgdesc = Xfce Applet ,that's show namedays
+ pkgver = r10.28f8af1
+ pkgrel = 1
+ url = https://m-opensource.eu
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ depends = libunique
+ provides = xfce4-nameday-plugin
+ source = git+https://gitlab.com/git-mp/xfce-stuff.git
+ md5sums = SKIP
+
+pkgname = xfce4-nameday-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..94e5a8e7b25d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: manky
+pkgname=xfce4-nameday-plugin-git
+_pkgname=xfce-nameday-plugin
+pkgver=r10.28f8af1
+pkgrel=1
+pkgdesc="Xfce Applet ,that's show namedays"
+url="https://m-opensource.eu"
+arch=('i686' 'x86_64')
+license=('GPL')
+provides=(xfce4-nameday-plugin)
+depends=('xfce4-panel' 'libunique')
+makedepends=('pkgconfig' 'xfce4-dev-tools' 'intltool' 'git')
+source=("git+https://gitlab.com/git-mp/xfce-stuff.git")
+md5sums=('SKIP')
+
+
+
+pkgver() {
+ cd "$srcdir/xfce-stuff/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ msg "Building..."
+ cd "$srcdir/xfce-stuff/${_pkgname}"
+ ./autogen.sh --prefix=/usr
+ make
+ msg "Building end"
+}
+
+package() {
+ cd "$srcdir/xfce-stuff/${_pkgname}"
+
+ make DESTDIR="$pkgdir/" install
+}