summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--button-visibility.patch15
-rw-r--r--fix-scrolling.patch125
4 files changed, 6 insertions, 163 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d75fb657eba..a6f92ad9d843 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-panel-compiz
pkgdesc = Panel for the Xfce desktop environment with fixes for Compiz
- pkgver = 4.14.3
+ pkgver = 4.14.4
pkgrel = 1
url = http://www.xfce.org/
arch = i686
@@ -17,18 +17,14 @@ pkgbase = xfce4-panel-compiz
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = libwnck3
- provides = xfce4-panel=4.14.3
+ provides = xfce4-panel=4.14.4
conflicts = xfce4-panel
- source = http://archive.xfce.org/src/xfce/xfce4-panel/4.14/xfce4-panel-4.14.3.tar.bz2
- source = button-visibility.patch
- source = fix-scrolling.patch
+ source = http://archive.xfce.org/src/xfce/xfce4-panel/4.14/xfce4-panel-4.14.4.tar.bz2
source = fix-scrolling2.patch
source = fix-scrolling3.patch
source = pager-dimensions.patch
source = wrap-workspaces.patch
- sha256sums = ef22324d26e5af735134bb10f85b6e16525ac9f48be8d2f6b634142fbfcabbc9
- sha256sums = 556f7ecc22fdf024101d2e8a0416b953efaef48ff4ed649aab97d5b115a94931
- sha256sums = 023fbeb4caa99dc97d460040f3d507794f3f576dc6cde98d834ba8a8e581f5ee
+ sha256sums = 8e5ea79412ba84cfada897ff309cbe2cd4aca16b9bd4f93df060229528576fd5
sha256sums = 2bbcace9c0c25c14fc1180a1064329240867a0b83c1c668aadc8c77f92ee0aab
sha256sums = 5e17300981a6030a2a3d4172b897e7aea0037401c8c9866cc03d82e0629c7fe2
sha256sums = 7055df37c000731057af828ef99ffb7193a18b3f2ab7dee541d79de029995cae
diff --git a/PKGBUILD b/PKGBUILD
index e9c5da5c394b..1d9d0997d2eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=xfce4-panel-compiz
_realname=xfce4-panel
-pkgver=4.14.3
+pkgver=4.14.4
pkgrel=1
pkgdesc="Panel for the Xfce desktop environment with fixes for Compiz"
arch=('i686' 'x86_64')
@@ -18,15 +18,11 @@ makedepends=('intltool' 'gtk-doc' 'xfce4-dev-tools')
provides=("$_realname=$pkgver")
conflicts=("$_realname")
source=(http://archive.xfce.org/src/xfce/$_realname/${pkgver%.*}/$_realname-$pkgver.tar.bz2
- button-visibility.patch
- fix-scrolling.patch
fix-scrolling2.patch
fix-scrolling3.patch
pager-dimensions.patch
wrap-workspaces.patch)
-sha256sums=('ef22324d26e5af735134bb10f85b6e16525ac9f48be8d2f6b634142fbfcabbc9'
- '556f7ecc22fdf024101d2e8a0416b953efaef48ff4ed649aab97d5b115a94931'
- '023fbeb4caa99dc97d460040f3d507794f3f576dc6cde98d834ba8a8e581f5ee'
+sha256sums=('8e5ea79412ba84cfada897ff309cbe2cd4aca16b9bd4f93df060229528576fd5'
'2bbcace9c0c25c14fc1180a1064329240867a0b83c1c668aadc8c77f92ee0aab'
'5e17300981a6030a2a3d4172b897e7aea0037401c8c9866cc03d82e0629c7fe2'
'7055df37c000731057af828ef99ffb7193a18b3f2ab7dee541d79de029995cae'
@@ -35,14 +31,6 @@ sha256sums=('ef22324d26e5af735134bb10f85b6e16525ac9f48be8d2f6b634142fbfcabbc9'
prepare() {
cd "$srcdir/$_realname-$pkgver"
- # See https://bugzilla.xfce.org/show_bug.cgi?id=10908
- echo "Applying button-visibility.patch:"
- #patch -p1 -i "$srcdir/button-visibility.patch"
-
- # See https://git.xfce.org/xfce/xfce4-panel/commit/?id=55dc7b400feef0c35fda3e8d3515dada2ced29c4
- echo "Applying fix-scrolling.patch:"
- #patch -p1 -i "$srcdir/fix-scrolling.patch"
-
# See https://bugzilla.xfce.org/show_bug.cgi?id=3361#c28
echo "Applying fix-scrolling2.patch:"
patch -p1 -i "$srcdir/fix-scrolling2.patch"
@@ -71,7 +59,6 @@ build() {
--disable-static \
--enable-gio-unix \
--enable-gtk-doc \
- --enable-gtk3 \
--disable-debug
make
}
diff --git a/button-visibility.patch b/button-visibility.patch
deleted file mode 100644
index a1b7c9bdc74e..000000000000
--- a/button-visibility.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Nur original/plugins/tasklist/tasklist-widget.c modified/plugins/tasklist/tasklist-widget.c
---- original/plugins/tasklist/tasklist-widget.c 2015-02-28 16:37:36.000000000 +0000
-+++ modified/plugins/tasklist/tasklist-widget.c 2015-09-05 16:16:03.799548200 +0100
-@@ -2633,6 +2633,11 @@
- else
- gtk_widget_hide (child->button);
- }
-+ /* initiate viewport switch on geometry change - fixes buttons not
-+ * getting updated when using compiz */
-+ active_ws = wnck_screen_get_active_workspace (child->tasklist->screen);
-+ if (wnck_workspace_is_virtual (active_ws))
-+ xfce_tasklist_viewports_changed (child->tasklist->screen, child->tasklist);
- }
-
-
diff --git a/fix-scrolling.patch b/fix-scrolling.patch
deleted file mode 100644
index 72f14bc0f45e..000000000000
--- a/fix-scrolling.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From 55dc7b400feef0c35fda3e8d3515dada2ced29c4 Mon Sep 17 00:00:00 2001
-From: Simon Steinbeiss <simon.steinbeiss@elfenbeinturm.at>
-Date: Thu, 15 Aug 2019 23:27:25 +0200
-Subject: pager: Fix scrolling in pager-buttons (Bug #15614)
-
-Unfortunately this doesn't affect the miniature view (aka WnckPager),
-where scrolling is handled natively and in a different - broken - order.
----
- common/panel-debug.c | 3 ++-
- common/panel-debug.h | 3 ++-
- plugins/pager/pager-buttons.c | 2 ++
- plugins/pager/pager.c | 32 +++++++++++++++++++++++++-------
- 4 files changed, 31 insertions(+), 9 deletions(-)
-
-diff --git a/common/panel-debug.c b/common/panel-debug.c
-index b554a98f..38af2854 100644
---- a/common/panel-debug.c
-+++ b/common/panel-debug.c
-@@ -54,7 +54,8 @@ static const GDebugKey panel_debug_keys[] =
- { "positioning", PANEL_DEBUG_POSITIONING },
- { "struts", PANEL_DEBUG_STRUTS },
- { "systray", PANEL_DEBUG_SYSTRAY },
-- { "tasklist", PANEL_DEBUG_TASKLIST }
-+ { "tasklist", PANEL_DEBUG_TASKLIST },
-+ { "pager", PANEL_DEBUG_PAGER }
- };
-
-
-diff --git a/common/panel-debug.h b/common/panel-debug.h
-index 9d882da9..56175658 100644
---- a/common/panel-debug.h
-+++ b/common/panel-debug.h
-@@ -42,7 +42,8 @@ typedef enum
- PANEL_DEBUG_POSITIONING = 1 << 12,
- PANEL_DEBUG_STRUTS = 1 << 13,
- PANEL_DEBUG_SYSTRAY = 1 << 14,
-- PANEL_DEBUG_TASKLIST = 1 << 15
-+ PANEL_DEBUG_TASKLIST = 1 << 15,
-+ PANEL_DEBUG_PAGER = 1 << 16
- }
- PanelDebugFlag;
-
-diff --git a/plugins/pager/pager-buttons.c b/plugins/pager/pager-buttons.c
-index fbac26fe..6c635be6 100644
---- a/plugins/pager/pager-buttons.c
-+++ b/plugins/pager/pager-buttons.c
-@@ -368,6 +368,7 @@ pager_buttons_rebuild_idle (gpointer user_data)
- vp_info[VIEWPORT_Y] = (n / (workspace_height / screen_height)) * screen_height;
-
- button = xfce_panel_create_toggle_button ();
-+ gtk_widget_add_events (GTK_WIDGET (button), GDK_SCROLL_MASK | GDK_SMOOTH_SCROLL_MASK);
- if (viewport_x >= vp_info[VIEWPORT_X] && viewport_x < vp_info[VIEWPORT_X] + screen_width
- && viewport_y >= vp_info[VIEWPORT_Y] && viewport_y < vp_info[VIEWPORT_Y] + screen_height)
- gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (button), TRUE);
-@@ -410,6 +411,7 @@ pager_buttons_rebuild_idle (gpointer user_data)
- workspace = WNCK_WORKSPACE (li->data);
-
- button = xfce_panel_create_toggle_button ();
-+ gtk_widget_add_events (GTK_WIDGET (button), GDK_SCROLL_MASK | GDK_SMOOTH_SCROLL_MASK);
- if (workspace == active_ws)
- gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (button), TRUE);
- g_signal_connect (G_OBJECT (button), "toggled",
-diff --git a/plugins/pager/pager.c b/plugins/pager/pager.c
-index 40cc7fab..5637bea6 100644
---- a/plugins/pager/pager.c
-+++ b/plugins/pager/pager.c
-@@ -32,6 +32,7 @@
- #include <common/panel-xfconf.h>
- #include <common/panel-utils.h>
- #include <common/panel-private.h>
-+#include <common/panel-debug.h>
- #include <libwnck/libwnck.h>
-
- #include "pager.h"
-@@ -320,11 +321,12 @@ static gboolean
- pager_plugin_scroll_event (GtkWidget *widget,
- GdkEventScroll *event)
- {
-- PagerPlugin *plugin = XFCE_PAGER_PLUGIN (widget);
-- WnckWorkspace *active_ws;
-- WnckWorkspace *new_ws;
-- gint active_n;
-- gint n_workspaces;
-+ PagerPlugin *plugin = XFCE_PAGER_PLUGIN (widget);
-+ WnckWorkspace *active_ws;
-+ WnckWorkspace *new_ws;
-+ gint active_n;
-+ gint n_workspaces;
-+ GdkScrollDirection scrolling_direction;
-
- panel_return_val_if_fail (WNCK_IS_SCREEN (plugin->wnck_screen), FALSE);
-
-@@ -332,11 +334,27 @@ pager_plugin_scroll_event (GtkWidget *widget,
- if (plugin->scrolling == FALSE)
- return TRUE;
-
-+ if (event->direction != GDK_SCROLL_SMOOTH)
-+ scrolling_direction = event->direction;
-+ else if (event->delta_y < 0)
-+ scrolling_direction = GDK_SCROLL_UP;
-+ else if (event->delta_y > 0)
-+ scrolling_direction = GDK_SCROLL_DOWN;
-+ else if (event->delta_x < 0)
-+ scrolling_direction = GDK_SCROLL_LEFT;
-+ else if (event->delta_x > 0)
-+ scrolling_direction = GDK_SCROLL_RIGHT;
-+ else
-+ {
-+ panel_debug_filtered (PANEL_DEBUG_PAGER, "Scrolling event with no delta happened.");
-+ return TRUE;
-+ }
-+
- active_ws = wnck_screen_get_active_workspace (plugin->wnck_screen);
- active_n = wnck_workspace_get_number (active_ws);
-
-- if (event->direction == GDK_SCROLL_UP
-- || event->direction == GDK_SCROLL_LEFT)
-+ if (scrolling_direction == GDK_SCROLL_UP
-+ || scrolling_direction == GDK_SCROLL_LEFT)
- active_n--;
- else
- active_n++;
---
-cgit v1.2.1
-