summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faacf0729ffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jul 17 18:16:39 UTC 2017
+pkgbase = xfce4-statusnotifier-plugin
+ pkgdesc = Plugin to status notifier indicators in the Xfce4 panel
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-statusnotifier-plugin
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = xfce4-panel
+ depends = libdbusmenu-gtk3
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-statusnotifier-plugin/0.1/xfce4-statusnotifier-plugin-0.1.0.tar.bz2
+ sha256sums = 22ad14101df914e79d4dbd8e5d96382b1d3f52e326d2acd7760bfbf9795ea6d5
+
+pkgname = xfce4-statusnotifier-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b102d7e18736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+pkgname=xfce4-statusnotifier-plugin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Plugin to status notifier indicators in the Xfce4 panel"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-statusnotifier-plugin"
+license=('GPL')
+depends=('xfce4-panel' 'libdbusmenu-gtk3')
+makedepends=('intltool')
+source=(http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
+sha256sums=('22ad14101df914e79d4dbd8e5d96382b1d3f52e326d2acd7760bfbf9795ea6d5')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --disable-static
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}