summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b4810c42fff..4b8f3d6d5f58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
-# Generated by mksrcinfo v8
-# Fri Oct 5 01:27:49 UTC 2018
pkgbase = xfce4-weather-plugin-git
pkgdesc = A weather plugin for the Xfce4 panel
- pkgver = 0.9.0+20+ga6f06d1
+ pkgver = 0.10.1+61+g6013d63
pkgrel = 1
url = http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin
- arch = i686
arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
groups = xfce4-goodies
license = GPL2
makedepends = intltool
@@ -17,9 +17,9 @@ pkgbase = xfce4-weather-plugin-git
depends = libsoup
depends = hicolor-icon-theme
depends = upower
- provides = xfce4-weather-plugin=0.9.0
+ provides = xfce4-weather-plugin=0.10.1
conflicts = xfce4-weather-plugin
- source = xfce4-weather-plugin::git://git.xfce.org/panel-plugins/xfce4-weather-plugin
+ source = xfce4-weather-plugin::git+https://gitlab.xfce.org/panel-plugins/xfce4-weather-plugin
sha256sums = SKIP
pkgname = xfce4-weather-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 16aed8ffb36c..bb67a944553c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_pkgname=xfce4-weather-plugin
pkgname=${_pkgname}-git
-pkgver=0.9.0+20+ga6f06d1
+pkgver=0.10.1+61+g6013d63
pkgrel=1
pkgdesc="A weather plugin for the Xfce4 panel"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
license=('GPL2')
groups=('xfce4-goodies')
@@ -13,12 +13,12 @@ depends=('xfce4-panel' 'libxml2' 'libsoup' 'hicolor-icon-theme' 'upower')
makedepends=('intltool' 'xfce4-dev-tools' 'git')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver%%+*}")
-source=("${_pkgname}::git://git.xfce.org/panel-plugins/${_pkgname}")
+source=("${_pkgname}::git+https://gitlab.xfce.org/panel-plugins/${_pkgname}")
sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
- git describe --long --tags | sed -r "s:^${_pkgname}.::;s:-:+:g" #s/^v//;s/([^-]*-g)/r\1/;s/-/./g"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^xfce-//;s/-/+/g"
}
build() {
@@ -39,5 +39,3 @@ package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: