summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f23c986c965..09f98f586870 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
-# Generated by mksrcinfo v8
-# Sun Jan 31 13:53:15 UTC 2016
pkgbase = xfstk-dldr
pkgdesc = Update Intel SoC firmware over USB using the DNX protocol
- pkgver = 1.8.1
- pkgrel = 1
- url = http://sourceforge.net/projects/xfstk/
- arch = x86
+ pkgver = 1.8.6
+ pkgrel = 3
+ url = https://github.com/edison-fw/xFSTK
+ arch = i686
arch = x86_64
license = LGPL
makedepends = doxygen
makedepends = graphviz
makedepends = cmake
depends = qt4
- depends = libusb
+ depends = libusb-compat
depends = boost
provides = xfstk-dldr
provides = xfstk-dldr-gui
conflicts = xfstk-dldr
conflicts = xfstk-dldr-gui
- source = http://sourceforge.net/projects/xfstk/files/xfstk-dldr-linux-source-1.8.1.tar.gz
- md5sums = c076b3bbbe9907ef2eb7958e17b152bd
+ source = git+https://github.com/edison-fw/xFSTK#tag=v1.8.6
+ sha256sums = SKIP
pkgname = xfstk-dldr
-
diff --git a/PKGBUILD b/PKGBUILD
index 073baa7aced0..efbaacaf4396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: Mihai Bisog <mihai.bisog@gmail.com>
+# Maintainer: kyngs <aurmail at kyngs dot xyz>
+# Contributor: Mihai Bisog <mihai.bisog@gmail.com>
pkgname=xfstk-dldr
-pkgver=1.8.1
-pkgrel=1
+pkgver=1.8.6
+pkgrel=3
pkgdesc="Update Intel SoC firmware over USB using the DNX protocol"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/xfstk/"
+url="https://github.com/edison-fw/xFSTK"
license=('LGPL')
-depends=('qt4' 'libusb' 'boost')
+depends=('qt4' 'libusb-compat' 'boost')
makedepends=('doxygen' 'graphviz' 'cmake')
provides=('xfstk-dldr' 'xfstk-dldr-gui')
conflicts=('xfstk-dldr' 'xfstk-dldr-gui')
-source=("http://sourceforge.net/projects/xfstk/files/$pkgname-linux-source-$pkgver.tar.gz")
-md5sums=("c076b3bbbe9907ef2eb7958e17b152bd")
+source=("git+${url}#tag=v$pkgver")
+sha256sums=('SKIP')
prepare() {
- cd "xfstk-build/linux-source-package"
+ cd "xFSTK"
mkdir -p build
cd build
BUILD_VERSION=$pkgver cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr
}
build() {
- cd "xfstk-build/linux-source-package/build"
+ cd "xFSTK/build"
make
}
package() {
- cd "xfstk-build/linux-source-package/build"
+ cd "xFSTK/build"
make DESTDIR="$pkgdir/" install
}