summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Rewrote-smartPlacement.patch10
-rw-r--r--0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch18
-rw-r--r--0003-Fix-new-window-always-top-left-when-screen-not-full.patch10
-rw-r--r--PKGBUILD12
5 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52083eb59dc6..e5643f0bf9fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 7 12:07:35 UTC 2016
+# Mon Mar 20 15:15:30 UTC 2017
pkgbase = xfwm4-better-smartplacement
pkgdesc = Xfce window manager w/ better smart placement of new windows
- pkgver = 4.12.3
- pkgrel = 2
+ pkgver = 4.12.4
+ pkgrel = 1
url = http://www.xfce.org/
arch = i686
arch = x86_64
@@ -17,14 +17,14 @@ pkgbase = xfwm4-better-smartplacement
provides = xfwm4
conflicts = xfwm4
options = !libtool
- source = http://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.3.tar.bz2
+ source = http://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.4.tar.bz2
source = 0001-Rewrote-smartPlacement.patch
source = 0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
source = 0003-Fix-new-window-always-top-left-when-screen-not-full.patch
- sha1sums = 9f7688bd444ff0517c72c5ed86c2de80d9bf6f2a
- sha1sums = ea46b6b9561bdd2e4f5225b4aeed811b2ed5d890
- sha1sums = e179b132c8da76a6b75e51bb7364e19ba9ecf7de
- sha1sums = 9356911cd08c9703f356c0b7993a6392302dbcad
+ sha1sums = d1019cce2a2f7978e36cb30fdc0f27cf9f626244
+ sha1sums = 54a9c4938f23554f9452e355577055980104c310
+ sha1sums = c50220a372564ebd83426176fc252782365c3872
+ sha1sums = 37fb87c433488b09447af1b0eb9e20e501ef4450
pkgname = xfwm4-better-smartplacement
diff --git a/0001-Rewrote-smartPlacement.patch b/0001-Rewrote-smartPlacement.patch
index a0afb151a85d..e6931540a8a5 100644
--- a/0001-Rewrote-smartPlacement.patch
+++ b/0001-Rewrote-smartPlacement.patch
@@ -1,4 +1,4 @@
-From 0f5d1078f3f903c7bc87c5c37a16a68cd2fd3825 Mon Sep 17 00:00:00 2001
+From 43f53e9bef9bc8004e4ab59e915de5a4202afa77 Mon Sep 17 00:00:00 2001
From: Olivier Brunel <jjk@jjacky.com>
Date: Sun, 8 Mar 2015 13:22:12 +0100
Subject: [PATCH 1/3] Rewrote smartPlacement()
@@ -17,10 +17,10 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 270 insertions(+), 144 deletions(-)
diff --git a/src/placement.c b/src/placement.c
-index 7b0ca22..a8e9c70 100644
+index e9a32c72..a6ce2636 100644
--- a/src/placement.c
+++ b/src/placement.c
-@@ -552,16 +552,139 @@ clientAutoMaximize (Client * c, int full_w, int full_h)
+@@ -543,16 +543,139 @@ clientAutoMaximize (Client * c, int full_w, int full_h)
}
static void
@@ -166,7 +166,7 @@ index 7b0ca22..a8e9c70 100644
g_return_if_fail (c != NULL);
TRACE ("entering smartPlacement");
-@@ -572,165 +695,168 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -563,165 +686,168 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
frame_left = frameExtentLeft(c);
frame_top = frameExtentTop (c);
@@ -474,5 +474,5 @@ index 7b0ca22..a8e9c70 100644
static void
--
-2.3.3
+2.12.0
diff --git a/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch b/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
index 8929961a55ef..425077b4f97f 100644
--- a/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
+++ b/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
@@ -1,4 +1,4 @@
-From d86b58c2ca82e10394d274bb5797bfa859e90de5 Mon Sep 17 00:00:00 2001
+From c91efb6c180e7b939addb4e65eddb100c48e0945 Mon Sep 17 00:00:00 2001
From: jjacky <i.am.jack.mail@gmail.com>
Date: Fri, 5 Apr 2013 15:22:11 +0200
Subject: [PATCH 2/3] smartPlacement: w/ snap_to_border we snap to bottom/right
@@ -13,10 +13,10 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 21 insertions(+), 12 deletions(-)
diff --git a/src/placement.c b/src/placement.c
-index a8e9c70..14969ec 100644
+index a6ce2636..41c48824 100644
--- a/src/placement.c
+++ b/src/placement.c
-@@ -711,7 +711,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -702,7 +702,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
Client *c2 = list->data;
gint i, n;
gboolean done;
@@ -25,7 +25,7 @@ index a8e9c70..14969ec 100644
gdouble best_surface = 0;
gboolean can_window_fit = FALSE;
-@@ -783,7 +783,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -774,7 +774,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
for (i = 0; i < n; ++i)
{
cairo_rectangle_int_t r;
@@ -34,7 +34,7 @@ index a8e9c70..14969ec 100644
gdouble exp_surface;
gboolean exp_can_window_fit;
gdouble surface;
-@@ -794,10 +794,9 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -785,10 +785,9 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
/* expand horizontally, then vertically */
expand_horizontal (region_hole, &rect, full_x, full_y, full_w, full_h);
expand_vertical (region_hole, &rect, full_x, full_y, full_w, full_h);
@@ -48,7 +48,7 @@ index a8e9c70..14969ec 100644
/* expand vertically, then horizontally */
expand_vertical (region_hole, &rect, full_x, full_y, full_w, full_h);
-@@ -811,9 +810,8 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -802,9 +801,8 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
|| (exp_can_window_fit && can_fit && surface < exp_surface))
{
exp_can_window_fit = can_fit;
@@ -59,7 +59,7 @@ index a8e9c70..14969ec 100644
}
/* is this the new best result ? (same criteria) */
-@@ -822,15 +820,14 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -813,15 +811,14 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
|| (can_window_fit && exp_can_window_fit && exp_surface < best_surface))
{
can_window_fit = exp_can_window_fit;
@@ -78,7 +78,7 @@ index a8e9c70..14969ec 100644
/* unless it could fit, make sure it's fully within monitor */
if (!can_window_fit)
-@@ -845,6 +842,18 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -836,6 +833,18 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
c->y -= n;
}
@@ -98,5 +98,5 @@ index a8e9c70..14969ec 100644
c->x += frame_left;
c->y += frame_top;
--
-2.3.3
+2.12.0
diff --git a/0003-Fix-new-window-always-top-left-when-screen-not-full.patch b/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
index 18ad8129db5e..47d08671015d 100644
--- a/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
+++ b/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
@@ -1,4 +1,4 @@
-From 68c37fbcd533ff2307c82f3b48bb090d9bbbd433 Mon Sep 17 00:00:00 2001
+From 73bbf7fed10ae33551892dcd7e029301ec826147 Mon Sep 17 00:00:00 2001
From: jjacky <i.am.jack.mail@gmail.com>
Date: Mon, 6 May 2013 11:00:51 +0200
Subject: [PATCH 3/3] Fix new window always top-left when screen not full
@@ -14,10 +14,10 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 4 insertions(+)
diff --git a/src/placement.c b/src/placement.c
-index 14969ec..a595f67 100644
+index 41c48824..19b02a84 100644
--- a/src/placement.c
+++ b/src/placement.c
-@@ -776,6 +776,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -767,6 +767,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
if (!region_hole)
break;
@@ -25,7 +25,7 @@ index 14969ec..a595f67 100644
cairo_region_destroy (region_monitor);
cairo_region_destroy (region_used);
-@@ -861,6 +862,9 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
+@@ -852,6 +853,9 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
return;
}
@@ -36,5 +36,5 @@ index 14969ec..a595f67 100644
cairo_region_destroy (region_used);
--
-2.3.3
+2.12.0
diff --git a/PKGBUILD b/PKGBUILD
index 25d87c0672e2..5e3608d2bce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=xfwm4
pkgname=$_pkgname-better-smartplacement
-pkgver=4.12.3
-pkgrel=2
+pkgver=4.12.4
+pkgrel=1
pkgdesc="Xfce window manager w/ better smart placement of new windows"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -20,10 +20,10 @@ source=(http://archive.xfce.org/src/xfce/${_pkgname}/4.12/${_pkgname}-${pkgver}.
0001-Rewrote-smartPlacement.patch
0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
0003-Fix-new-window-always-top-left-when-screen-not-full.patch)
-sha1sums=('9f7688bd444ff0517c72c5ed86c2de80d9bf6f2a'
- 'ea46b6b9561bdd2e4f5225b4aeed811b2ed5d890'
- 'e179b132c8da76a6b75e51bb7364e19ba9ecf7de'
- '9356911cd08c9703f356c0b7993a6392302dbcad')
+sha1sums=('d1019cce2a2f7978e36cb30fdc0f27cf9f626244'
+ '54a9c4938f23554f9452e355577055980104c310'
+ 'c50220a372564ebd83426176fc252782365c3872'
+ '37fb87c433488b09447af1b0eb9e20e501ef4450')
prepare() {
cd ${srcdir}/${_pkgname}-${pkgver}