summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--xg3utility.15
-rw-r--r--xg3utility.desktop14
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90be5087cbff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xg3utility
+ pkgdesc = Elecraft Factory APP for use with the XG3 Generator - Ham Radio.
+ pkgver = 19_9_6
+ pkgrel = 1
+ url = https://ftp.elecraft.com/XG3/Manuals%20Downloads/
+ arch = x86_64
+ license = custom:ELECRAFT
+ depends = gcc-libs
+ depends = gtk2
+ depends = curl
+ depends = hamradio-menus
+ options = !strip
+ source = https://ftp.elecraft.com/XG3/Utilities/XG3UtilityLINUX64BIT_19_9_6.tar.gz
+ source = xg3utility.1
+ source = xg3utility.desktop
+ md5sums = 9cfe876d6e1220d29ee22e1904e1fd98
+ md5sums = 9b109dc79ad4195f9a937f0482cb4324
+ md5sums = 1aed68a5d4c8631f0027156eaebe62a3
+ sha256sums = f0592a133d0e86fccf57413c89e096f8207a983a7a10aa9b49745d382c75df1e
+ sha256sums = de9c77223d69dbbf2d5fc451a3128dd53dcf326cee577cb9b2340e22367e5cc1
+ sha256sums = 3b08d63227279cd82d0703dfcc7f66cfa1d5b3a7f28c188b13672f1460fb7563
+
+pkgname = xg3utility
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e437be32d533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=xg3utility
+_pkgname=XG3UtilityLINUX64BIT
+__pkgname=XG3UtilityLINUX
+pkgver=19_9_6
+pkgrel=1
+pkgdesc="Elecraft Factory APP for use with the XG3 Generator - Ham Radio."
+arch=('x86_64')
+url="https://ftp.elecraft.com/XG3/Manuals%20Downloads/"
+license=('custom:ELECRAFT')
+depends=('gcc-libs' 'gtk2' 'curl' 'hamradio-menus')
+options=('!strip')
+source=(https://ftp.elecraft.com/XG3/Utilities/${_pkgname}_$pkgver.tar.gz
+ $pkgname.1
+ $pkgname.desktop)
+
+package() {
+ cd $srcdir/${__pkgname}_$pkgver
+
+ install -d $pkgdir/usr/share/$pkgname
+ cp -a * $pkgdir/usr/share/$pkgname
+
+ mkdir -p $pkgdir/usr/bin
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps,licenses/$pkgname}
+ install -D -m 644 Help/XG3UtilityLicense.rtf $pkgdir/usr/share/licenses/$pkgname
+ install -D -m 644 Resources/icon-48.png $pkgdir/usr/share/pixmaps/xg3utility.png
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+
+ chmod 644 $pkgdir/usr/share/$pkgname/Help/*
+}
+md5sums=('9cfe876d6e1220d29ee22e1904e1fd98'
+ '9b109dc79ad4195f9a937f0482cb4324'
+ '1aed68a5d4c8631f0027156eaebe62a3')
+sha256sums=('f0592a133d0e86fccf57413c89e096f8207a983a7a10aa9b49745d382c75df1e'
+ 'de9c77223d69dbbf2d5fc451a3128dd53dcf326cee577cb9b2340e22367e5cc1'
+ '3b08d63227279cd82d0703dfcc7f66cfa1d5b3a7f28c188b13672f1460fb7563')
diff --git a/xg3utility.1 b/xg3utility.1
new file mode 100644
index 000000000000..b662c8571404
--- /dev/null
+++ b/xg3utility.1
@@ -0,0 +1,5 @@
+#!/bin/sh
+mkdir -p $HOME/xg3utility
+cd $HOME/xg3utility
+cp -ua /usr/share/xg3utility/* .
+exec ./xg3util
diff --git a/xg3utility.desktop b/xg3utility.desktop
new file mode 100644
index 000000000000..535e582f1517
--- /dev/null
+++ b/xg3utility.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=XG3-Utility
+Name[en_US]=XG3-Utility
+Comment=Elecraft XG3 Control Utility
+Comment[en_US]=Elecraft XG3 Control Utility
+Exec=xg3utility
+Icon=xg3utility
+MimeType=text/plain
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Network;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false