summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--python_no_libs.patch6
2 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff8ac892f09d..5dcb43ad7988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=xgboost-git
pkgname=('xgboost-git'
'python-xgboost-git'
'python2-xgboost-git')
-pkgver=r2737.c9a73fe
+pkgver=r2828.ecec5f7
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
@@ -19,7 +19,7 @@ arch=('x86_64')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'fd317b9708da75b4e2e304b5c2eacbb4b766bb38044e3a26ce55d077c2e13048'
+ '610f3ec61f30907eab32ca00ebe84ca0bc5d5566d462ed9c477b130c02f38a74'
'5c22abd1a58f0b6da16687e3083a3dbbb961f30f0de359c5637cdbc1948459af')
pkgver() {
diff --git a/python_no_libs.patch b/python_no_libs.patch
index b59590db79fa..9563e893f8a0 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -32,13 +32,13 @@ diff --git a/python-package/xgboost/libpath.py b/python-package/xgboost/libpath.
index 2d69bda..d3ee109 100644
--- a/python-package/xgboost/libpath.py
+++ b/python-package/xgboost/libpath.py
-@@ -20,7 +20,8 @@ def find_lib_path():
+@@ -21,7 +21,8 @@
"""
curr_path = os.path.dirname(os.path.abspath(os.path.expanduser(__file__)))
# make pythonpack hack: copy this directory one level upper for setup.py
- dll_path = [curr_path, os.path.join(curr_path, '../../lib/'),
+ dll_path = ["/usr/lib", curr_path,
+ os.path.join(curr_path, '../../lib/'),
- os.path.join(curr_path, './lib/')]
+ os.path.join(curr_path, './lib/'),
+ os.path.join(sys.prefix, 'xgboost')]
if os.name == 'nt':
- if platform.architecture()[0] == '64bit':