summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
-rw-r--r--xgboost_fix_missing_include.patch12
2 files changed, 2 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dcb43ad7988..a9c32ca6e104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,15 +12,13 @@ license=('APACHE')
source=('git+https://github.com/dmlc/xgboost.git'
'git+https://github.com/dmlc/dmlc-core'
'git+https://github.com/dmlc/rabit'
- 'python_no_libs.patch'
- 'xgboost_fix_missing_include.patch')
+ 'python_no_libs.patch')
makedepends=('python2-setuptools' 'python-setuptools')
arch=('x86_64')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '610f3ec61f30907eab32ca00ebe84ca0bc5d5566d462ed9c477b130c02f38a74'
- '5c22abd1a58f0b6da16687e3083a3dbbb961f30f0de359c5637cdbc1948459af')
+ '610f3ec61f30907eab32ca00ebe84ca0bc5d5566d462ed9c477b130c02f38a74')
pkgver() {
cd "${_name}"
@@ -34,7 +32,6 @@ prepare() {
git config submodule.rabit.url "${srcdir}/rabit"
git submodule update
patch -p1 < "${srcdir}/python_no_libs.patch"
- grep -qF '<cmath>' src/tree/param.h || patch -p1 < "${srcdir}/xgboost_fix_missing_include.patch"
}
build() {
diff --git a/xgboost_fix_missing_include.patch b/xgboost_fix_missing_include.patch
deleted file mode 100644
index a10776888adc..000000000000
--- a/xgboost_fix_missing_include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/tree/param.h b/src/tree/param.h
-index e9de3ac..23d0c5b 100644
---- a/src/tree/param.h
-+++ b/src/tree/param.h
-@@ -9,6 +9,7 @@
-
- #include <vector>
- #include <cstring>
-+#include <cmath>
-
- namespace xgboost {
- namespace tree {