summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ada0d0f18af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xgraph-bin
+ pkgdesc = XGRAPH is a general purpose x-y data plotter with interactive buttons for panning, zooming, printing, and selecting display options.
+ pkgver = 4.30
+ pkgrel = 1
+ url = http://www.xgraph.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libx11
+ optdepends = netpbm
+ conflicts = xgraph
+ source_i686 = http://www.xgraph.org/linux/xgraph_4.30_linux32.tar.gz
+ md5sums_i686 = 14e0f03d18451ce2e6c2d5cdb25227af
+ source_x86_64 = http://www.xgraph.org/linux/xgraph_4.30_linux64.tar.gz
+ md5sums_x86_64 = 976827671b1c0ebbdb2092d1b1e71aac
+
+pkgname = xgraph-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab4b3088747e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# PKGBUILD for xgraph from http://www.xgraph.org/
+# Maintainer: ThanosApostolou <thanosapostolou@outlook.com>]
+
+pkgname=xgraph-bin
+pkgver=4.30
+pkgrel=1
+pkgdesc="XGRAPH is a general purpose x-y data plotter with interactive buttons for panning, zooming, printing, and selecting display options."
+arch=('i686' 'x86_64')
+url="http://www.xgraph.org/"
+license=('custom')
+depends=('libx11')
+optdepends=('netpbm')
+conflicts=('xgraph')
+source=()
+source_i686=("http://www.xgraph.org/linux/xgraph_4.30_linux32.tar.gz")
+source_x86_64=("http://www.xgraph.org/linux/xgraph_4.30_linux64.tar.gz")
+
+package() {
+ cd "$pkgdir"
+ mkdir -p "$pkgdir/usr/bin/"
+ if test "$CARCH" == x86_64; then
+ install -m 755 "$srcdir"/XGraph4.30_linux64/bin/xgraph "$pkgdir/usr/bin/"
+ elif test "$CARCH" == i686; then
+ install -m 755 "$srcdir"/XGraph4.30_linux32/bin/xgraph "$pkgdir/usr/bin/"
+ fi
+}
+md5sums_i686=('14e0f03d18451ce2e6c2d5cdb25227af')
+md5sums_x86_64=('976827671b1c0ebbdb2092d1b1e71aac')