summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD30
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51b938c84150
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xiccd
+ pkgdesc = Simple bridge between colord and X
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/agalakhov/xiccd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = colord
+ depends = libxrandr
+ source = https://github.com/agalakhov/xiccd/archive/v0.2.2.tar.gz
+ sha1sums = 45831c211fe7eafc13c36f0fce9549c42373380d
+
+pkgname = xiccd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3889b6ca9753
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+**/pkg/
+**/src/
+*.pkg.tar.xz
+*.tar.bz2
+*.tar.gz
+*.tgz
+*.tar.xz
+*.rpm
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcc8ad7ce3f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: John K. Luebs <jkluebs@luebsphoto.com>
+pkgname=xiccd
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Simple bridge between colord and X"
+arch=(i686 x86_64)
+url="https://github.com/agalakhov/xiccd"
+license=(GPL)
+depends=(colord libxrandr)
+source=(https://github.com/agalakhov/${pkgname}/archive/v${pkgver}.tar.gz)
+sha1sums=('45831c211fe7eafc13c36f0fce9549c42373380d')
+
+build() {
+ cd $pkgname-$pkgver
+
+ aclocal
+ autoconf
+ automake --add-missing --foreign --force --copy
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: