summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--xineliboutput-vdr2.1.10compat.diff19
-rw-r--r--xineliboutput-vdr2.1.6compat.diff29
-rw-r--r--xineliboutput_fix_vdrversion_check.diff24
-rw-r--r--xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff13
6 files changed, 44 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e86101b22b..d259a63b89d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by makepkg 5.0.1
+# Sun Aug 21 08:36:14 UTC 2016
pkgbase = xineliboutput
- pkgver = 1.1.0.32.gbf166be
- pkgrel = 11
+ pkgver = 1.1.0.55.g9027ea1
+ pkgrel = 1
url = http://www.sourceforge.net/projects/xineliboutput
arch = x86_64
arch = i686
@@ -16,15 +18,11 @@ pkgbase = xineliboutput
makedepends = mesa
makedepends = vdr-api=2.2.0
makedepends = xine-lib
- source = git://projects.vdr-developer.org/xineliboutput.git#commit=bf166be4a21c0a86f6852c4695dcdb06863f4e93
- source = xineliboutput-vdr2.1.6compat.diff
- source = xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff
- source = xineliboutput-vdr2.1.10compat.diff
+ source = git://git.code.sf.net/p/xineliboutput/git#commit=9027ea1737b966386916da27207e8bf92f24cfe0
+ source = xineliboutput_fix_vdrversion_check.diff
source = 50-xineliboutput.conf
md5sums = SKIP
- md5sums = 14ef92cd38503a2f426669aa43b0aeb4
- md5sums = d9e14cb60e536109716ebc886f54880b
- md5sums = de80424deabba49e3f40c2f92f640765
+ md5sums = d1f1c591b9f927fd0b86e7ff19c09951
md5sums = a9a3cd09b950d2024b21a1c6e0620506
pkgname = vdr-xineliboutput
diff --git a/PKGBUILD b/PKGBUILD
index 0029b74b2321..b17a9b9d7344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,34 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgbase=xineliboutput
pkgname=(vdr-xineliboutput xineliboutput-frontends xineliboutput-xineplug)
-pkgver=1.1.0.32.gbf166be
-_gitver=bf166be4a21c0a86f6852c4695dcdb06863f4e93
+pkgver=1.1.0.55.g9027ea1
+_gitver=9027ea1737b966386916da27207e8bf92f24cfe0
_vdrapi=2.2.0
-pkgrel=11
+pkgrel=1
url="http://www.sourceforge.net/projects/xineliboutput"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
makedepends=('dbus-glib' 'git' 'glu' 'libextractor' 'libxrandr' 'mesa' "vdr-api=${_vdrapi}" 'xine-lib')
_plugname=${pkgname//vdr-/}
-source=("git://projects.vdr-developer.org/$_plugname.git#commit=$_gitver"
- 'xineliboutput-vdr2.1.6compat.diff'
- 'xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff'
- 'xineliboutput-vdr2.1.10compat.diff'
+source=("git://git.code.sf.net/p/xineliboutput/git#commit=$_gitver"
+ 'xineliboutput_fix_vdrversion_check.diff'
"50-$_plugname.conf")
md5sums=('SKIP'
- '14ef92cd38503a2f426669aa43b0aeb4'
- 'd9e14cb60e536109716ebc886f54880b'
- 'de80424deabba49e3f40c2f92f640765'
+ 'd1f1c591b9f927fd0b86e7ff19c09951'
'a9a3cd09b950d2024b21a1c6e0620506')
pkgver() {
- cd "${srcdir}/${_plugname}"
+ cd "${srcdir}/git"
git describe --tags | sed "s/$_plugname.//g;s/_/./g;s/-/./g"
}
prepare() {
- cd "${srcdir}/${_plugname}"
- patch -p1 -i "$srcdir/xineliboutput-vdr2.1.6compat.diff"
- patch -p1 -i "$srcdir/xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff"
- patch -p1 -i "$srcdir/xineliboutput-vdr2.1.10compat.diff"
+ cd "${srcdir}/git"
+ patch -p1 -i "$srcdir/xineliboutput_fix_vdrversion_check.diff"
}
build() {
- cd "${srcdir}/${_plugname}"
+ cd "${srcdir}/git"
./configure --disable-libcec
make
}
@@ -48,7 +42,7 @@ package_vdr-xineliboutput() {
'xorg-server: Required for software decoding')
backup=("etc/vdr/conf.avail/50-$_plugname.conf"
"var/lib/vdr/plugins/$_plugname/allowed_hosts.conf")
- cd "${srcdir}/${_plugname}"
+ cd "${srcdir}/git"
mkdir -p "$pkgdir/usr/lib/vdr/plugins"
make DESTDIR="$pkgdir" install
@@ -66,7 +60,7 @@ package_xineliboutput-frontends() {
depends=('dbus-glib' 'libxrandr' 'mesa' 'xine-lib' 'xineliboutput-xineplug')
optdepends=('nvidia: Required for VDPAU decoding'
'xorg-server: Required for software decoding')
- cd "${srcdir}/${_plugname}"
+ cd "${srcdir}/git"
mkdir -p "$pkgdir/usr/lib/vdr/plugins"
make DESTDIR="$pkgdir" install
@@ -76,7 +70,7 @@ package_xineliboutput-frontends() {
package_xineliboutput-xineplug() {
pkgdesc="Neccessary xine plugins for xineliboutput-frontends and vdr-xineliboutput"
depends=('xine-lib')
- cd "${srcdir}/${_plugname}"
+ cd "${srcdir}/git"
mkdir -p "$pkgdir/usr/lib/vdr/plugins"
make DESTDIR="$pkgdir" install
diff --git a/xineliboutput-vdr2.1.10compat.diff b/xineliboutput-vdr2.1.10compat.diff
deleted file mode 100644
index 3c6f8a61eeec..000000000000
--- a/xineliboutput-vdr2.1.10compat.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/osd.c b/osd.c
-index a6a4552..42b7d36 100644
---- a/osd.c
-+++ b/osd.c
-@@ -515,12 +515,12 @@ void cXinelibOsd::Flush(void)
- if (IsTrueColor()) {
-
- LOCK_PIXMAPS;
-- while (cPixmapMemory *pm = RenderPixmaps()) {
-+ while (cPixmapMemory *pm = dynamic_cast<cPixmapMemory *>(RenderPixmaps())) {
- int w = pm->ViewPort().Width();
- int h = pm->ViewPort().Height();
- int d = w * sizeof(tColor);
- CmdArgb(Left() + pm->ViewPort().X(), Top() + pm->ViewPort().Y(), w, h, pm->Data(), h * d);
-- delete pm;
-+ DestroyPixmap(pm);
- }
-
- return;
diff --git a/xineliboutput-vdr2.1.6compat.diff b/xineliboutput-vdr2.1.6compat.diff
deleted file mode 100644
index a8252c2ce553..000000000000
--- a/xineliboutput-vdr2.1.6compat.diff
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/device.c b/device.c
-index 081fb64..ed1595b 100644
---- a/device.c
-+++ b/device.c
-@@ -1441,12 +1441,6 @@ void cXinelibDevice::SetVideoDisplayFormat(eVideoDisplayFormat VideoDisplayForma
- #endif
- }
-
--eVideoSystem cXinelibDevice::GetVideoSystem(void)
--{
-- TRACEF("cXinelibDevice::GetVideoSystem");
-- return cDevice::GetVideoSystem();
--}
--
- void cXinelibDevice::GetVideoSize(int &Width, int &Height, double &VideoAspect)
- {
- Width = m_VideoSize->width;
-diff --git a/device.h b/device.h
-index c86a99f..a01e017 100644
---- a/device.h
-+++ b/device.h
-@@ -123,7 +123,6 @@ class cXinelibDevice : public cDevice
- public:
- virtual void SetVideoDisplayFormat(eVideoDisplayFormat VideoDisplayFormat);
- virtual void SetVideoFormat(bool VideoFormat16_9);
-- virtual eVideoSystem GetVideoSystem(void);
-
- struct video_size_s *m_VideoSize;
- struct ts_state_s *m_tssVideoSize;
diff --git a/xineliboutput_fix_vdrversion_check.diff b/xineliboutput_fix_vdrversion_check.diff
new file mode 100644
index 000000000000..e48fe4dfac30
--- /dev/null
+++ b/xineliboutput_fix_vdrversion_check.diff
@@ -0,0 +1,24 @@
+diff -upr a/device.c b/device.c
+--- a/device.c 2016-08-20 11:41:20.856830323 +0200
++++ b/device.c 2016-08-20 11:46:48.853501033 +0200
+@@ -1457,7 +1457,7 @@ void cXinelibDevice::SetVideoDisplayForm
+ #endif
+ }
+
+-#if VDRVERSNUM < 20301
++#if VDRVERSNUM < 20200
+ eVideoSystem cXinelibDevice::GetVideoSystem(void)
+ {
+ TRACEF("cXinelibDevice::GetVideoSystem");
+diff -upr a/device.h b/device.h
+--- a/device.h 2016-08-20 11:41:20.856830323 +0200
++++ b/device.h 2016-08-20 11:46:52.500167744 +0200
+@@ -123,7 +123,7 @@ class cXinelibDevice : public cDevice
+ public:
+ virtual void SetVideoDisplayFormat(eVideoDisplayFormat VideoDisplayFormat);
+ virtual void SetVideoFormat(bool VideoFormat16_9);
+-#if VDRVERSNUM < 20301
++#if VDRVERSNUM < 20200
+ virtual eVideoSystem GetVideoSystem(void);
+ #endif
+
diff --git a/xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff b/xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff
deleted file mode 100644
index fef0e5540a22..000000000000
--- a/xineliboutput_renamed_iDoubleTapTimeoutMs_in_libcec.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/xine_frontend_cec.c b/xine_frontend_cec.c
-index 02e44f0..461bc4f 100644
---- a/xine_frontend_cec.c
-+++ b/xine_frontend_cec.c
-@@ -272,7 +272,7 @@ static void libcec_config_clear(libcec_configuration *p)
- p->bMonitorOnly = 0;
- p->cecVersion = CEC_DEFAULT_SETTING_CEC_VERSION;
- p->adapterType = ADAPTERTYPE_UNKNOWN;
-- p->iDoubleTapTimeoutMs = CEC_DOUBLE_TAP_TIMEOUT_MS;
-+ p->iDoubleTapTimeout50Ms = CEC_DOUBLE_TAP_TIMEOUT_50_MS;
- p->comboKey = CEC_USER_CONTROL_CODE_STOP;
- p->iComboKeyTimeoutMs = CEC_DEFAULT_COMBO_TIMEOUT_MS;
-