summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--xiphos.install13
3 files changed, 20 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f9428e677e5..4240581207ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,27 @@
# Generated by mksrcinfo v8
-# Tue Dec 22 15:11:50 UTC 2015
+# Thu Oct 5 03:51:07 UTC 2017
pkgbase = xiphos
pkgdesc = Bible study tool for GTK+
- pkgver = 4.0.4
+ pkgver = 4.0.7
pkgrel = 1
url = http://xiphos.org/
- install = xiphos.install
arch = x86_64
arch = i686
license = GPL
+ makedepends = gnome-common
makedepends = gnome-doc-utils
makedepends = intltool
makedepends = python2
+ depends = sword
depends = webkitgtk2
depends = libgsf
depends = libglade
- depends = gtkhtml3
- depends = sword
+ depends = gtkhtml4
depends = biblesync
provides = gnomesword
conflicts = gnomesword
- replaces = gnomesword
- source = http://downloads.sourceforge.net/gnomesword/xiphos-4.0.4-20150830.tar.gz
- md5sums = a1d88b7d6812fd261d71a229999c669d
+ source = xiphos-4.0.7.tar.gz::https://github.com/crosswire/xiphos/archive/4.0.7.tar.gz
+ sha512sums = 041e0e9c6a7406b02c5b45066b44a3d44c37a34a799c3dfd617b6aa52dc50efbf800e475e107108fcf1d0d23a3522d0a9fa0838c474d2e4dd39f3af9d3429bd4
pkgname = xiphos
diff --git a/PKGBUILD b/PKGBUILD
index 1a55f1885175..da22f6ee04eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,33 @@
-# Maintainer: Vonpupp <vonpupp@gmail.com>
-# Contributor: Menche <menche_mt at yahoo dot com>
-# Contributor: Alexander Rødseth <rodseth@gmail.com>
-# Contributor: Andrea Scarpino
-# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: TripleE <eric1548@yahoo.com>
+# Contributor: Christopher Bayliss <christopher.j.bayliss@gmail.com>
+# co-Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=xiphos
pkgver=4.0.7
pkgrel=1
-_pkgdate=20170924
+pkgdesc="A Bible study tool for GTK3"
+arch=('i686' 'x86_64')
+url="http://xiphos.org"
pkgdesc="Bible study tool for GTK+"
arch=('x86_64' 'i686')
url="http://xiphos.org/"
depends=('sword' 'webkitgtk2' 'libgsf' 'libglade' 'gtkhtml4' 'biblesync')
-makedepends=('gnome-doc-utils' 'intltool' 'python2')
+makedepends=('gnome-common' 'gnome-doc-utils' 'intltool' 'python2')
license=('GPL')
-conflicts=('gnomesword')
provides=('gnomesword')
-replaces=('gnomesword')
-install=xiphos.install
-source=("https://github.com/crosswire/xiphos/releases/download/$pkgver/$pkgname-$pkgver-$_pkgdate.tar.gz")
+conflicts=('gnomesword')
+source=("xiphos-${pkgver}.tar.gz::https://github.com/crosswire/xiphos/archive/${pkgver}.tar.gz")
sha512sums=('041e0e9c6a7406b02c5b45066b44a3d44c37a34a799c3dfd617b6aa52dc50efbf800e475e107108fcf1d0d23a3522d0a9fa0838c474d2e4dd39f3af9d3429bd4')
build() {
cd "$pkgname-$pkgver"
sed -i '0,/python/s//python2/' waf
- ./waf configure --gtk=3 --prefix=/usr --enable-webkit2
- ./waf build
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 configure
+ python2 ./waf --prefix=/usr --gtk=3 --enable-webkit2 build
}
package() {
- cd "$pkgname-$pkgver"
-
- ./waf install --destdir="$pkgdir"
+ cd "xiphos-${pkgver}"
+ python2 ./waf --destdir=$pkgdir --no-post-install install
}
+
diff --git a/xiphos.install b/xiphos.install
deleted file mode 100644
index 048e777804e1..000000000000
--- a/xiphos.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
-# vim:set ts=2 sw=2 et: