summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0234eaadb344..0f728ffcd10e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,20 +13,19 @@ provides=('gnomesword' 'xiphos')
conflicts=('gnomesword' 'xiphos')
source=(git+https://github.com/crosswire/xiphos.git)
md5sums=('SKIP')
-_gitname=xiphos
pkgver() {
- cd "$_gitname"
+ cd ${pkgname%-git}
printf "r%s" $(git rev-list --count HEAD)
}
build() {
- cd "$_gitname"
+ cd ${pkgname%-git}
CXX=g++ python2 ./waf --prefix=/usr --enable-webkit2 configure
python2 ./waf --prefix=/usr --enable-webkit2 build
}
package() {
- cd "$_gitname"
- python2 ./waf --destdir=$pkgdir --no-post-install install
+ cd ${pkgname%-git}
+ python2 ./waf --destdir="$pkgdir" --no-post-install install
}