summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9a497de10fd..100697ff8c9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = xkbset
- pkgdesc = Program to help manage many of XKB features of X window.
- pkgver = 0.5
- pkgrel = 2
- url = http://www.math.missouri.edu/~stephen/software/#xkbset
+ pkgdesc = Manage most of the options of XKB extensions from X window interface.
+ pkgver = 0.8
+ pkgrel = 4
+ url = https://github.com/stephenmontgomerysmith/xkbset
arch = i686
arch = x86_64
license = custom:BSD
- makedepends = coreutils
+ makedepends = git
depends = libx11
- optdepends = perl-tk
- source = http://www.math.missouri.edu/~stephen/software/xkbset/xkbset-0.5.tar.gz
- md5sums = 282c416a76a237fa84a7b513c9d7b2cf
+ optdepends = perl-tk: to use the xkbset-gui program
+ provides = xkbset
+ conflicts = xkbset-git
+ source = https://github.com/stephenmontgomerysmith/xkbset/archive/refs/tags/v0.8.tar.gz
+ sha256sums = 23c2397f16473611ca16eddbb5b144da1f02b2765183b8b4f99e17031488ea6a
pkgname = xkbset
-
diff --git a/PKGBUILD b/PKGBUILD
index 085e23fc8d7f..37ca482886c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,20 @@
-# Maintainer: sputnick <gilles *dot* quenot *at* gmail>
+# Maintainer: ramen <hendrikschick@hndrkk.sh>
+# Contributor: sputnick <gilles *dot* quenot *at* gmail>
# Contributor: MaurĂ­cio CA <mauricio.antunes@gmail.com>
pkgname=xkbset
-pkgver=0.5
-pkgrel=3
-pkgdesc="Program to help manage many of XKB features of X window."
+pkgver=0.8
+pkgrel=4
+pkgdesc="Manage most of the options of XKB extensions from X window interface."
arch=(i686 x86_64)
-url="http://www.math.missouri.edu/~stephen/software/#xkbset"
+url="https://github.com/stephenmontgomerysmith/xkbset"
license=('custom:BSD')
-groups=()
-depends=(libx11)
-makedepends=(coreutils)
-optdepends=(perl-tk)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=(http://faculty.missouri.edu/~stephen/software/xkbset/$pkgname-$pkgver.tar.gz)
-noextract=()
-md5sums=('282c416a76a237fa84a7b513c9d7b2cf')
+depends=('libx11')
+makedepends=('git')
+optdepends=('perl-tk: to use the xkbset-gui program')
+provides=('xkbset')
+conflicts=('xkbset-git')
+source=( "https://github.com/stephenmontgomerysmith/xkbset/archive/refs/tags/v$pkgver.tar.gz" )
+sha256sums=('23c2397f16473611ca16eddbb5b144da1f02b2765183b8b4f99e17031488ea6a')
build() {
sed -r \
@@ -37,6 +31,5 @@ package() {
install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
}
-
-# vim:set ts=2 sw=2 et: