summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE18
-rw-r--r--PKGBUILD42
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ceb323463f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = xlockmore-blank
+ pkgdesc = screen saver / locker for the X Window System - blank only
+ pkgver = 5.46
+ pkgrel = 1
+ url = http://www.tux.org/~bagleyd/xlockmore.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = libxinerama
+ depends = mesa
+ depends = freetype2
+ depends = libxpm
+ depends = libxmu
+ depends = glu
+ optdepends = fortune-mod
+ provides = xlockmore
+ conflicts = xlockmore
+ conflicts = xlockmore-nomotif
+ options = !makeflags
+ source = http://www.tux.org/~bagleyd/xlock/xlockmore-5.46.tar.xz
+ source = LICENSE
+ md5sums = 068b9c2bfbcdd02461edbac4d729cd27
+ md5sums = a64afab4283f53972a6702c2e59850d7
+
+pkgname = xlockmore-blank
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f0b9aa9c61f2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,18 @@
+/*-
+ * xscreensaver compatibility layer for xlockmore modules.
+ * xscreensaver, Copyright (c) 1997, 1998 Jamie Zawinski <jwz@jwz.org>
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and its
+ * documentation for any purpose is hereby granted without fee, provided that
+ * the above copyright notice appear in all copies and that both that
+ * copyright notice and this permission notice appear in supporting
+ * documentation. No representations are made about the suitability of this
+ * software for any purpose. It is provided "as is" without express or
+ * implied warranty.
+ *
+ * This file, along with xlockmore.h, make it possible to compile an xlockmore
+ * module into a standalone program, and thus use it with xscreensaver.
+ * By Jamie Zawinski <jwz@jwz.org> on 10-May-97; based on the ideas
+ * in the older xlock.h by Charles Hannum <mycroft@ai.mit.edu>. (I had
+ * to redo it, since xlockmore has diverged so far from xlock...)
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6db9c664a829
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 96760 2013-09-04 10:17:31Z spupykin $
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: dorphell <dorphell@archlinux.org>
+
+pkgname=xlockmore-blank
+_pkgname=xlockmore
+pkgver=5.46
+pkgrel=1
+pkgdesc="screen saver / locker for the X Window System - blank only"
+arch=(i686 x86_64)
+license=('BSD')
+depends=(libxinerama mesa freetype2 libxpm libxmu glu)
+optdepends=('fortune-mod')
+provides=("$_pkgname")
+conflicts=("$_pkgname" "$_pkgname-nomotif")
+url="http://www.tux.org/~bagleyd/xlockmore.html"
+options=('!makeflags')
+source=(http://www.tux.org/~bagleyd/xlock/xlockmore-$pkgver.tar.xz
+ LICENSE)
+md5sums=('068b9c2bfbcdd02461edbac4d729cd27'
+ 'a64afab4283f53972a6702c2e59850d7')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr --disable-setuid \
+ --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ --enable-pam --with-gtk2 --without-esound --without-ftgl \
+ --without-motif --without-magick --without-rplay \
+ --without-gtk --without-gtk2 --enable-blank-only
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make xapploaddir="$pkgdir/usr/share/X11/app-defaults" \
+ mandir="$pkgdir/usr/man/man1" \
+ prefix="$pkgdir/usr" install
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mv "$pkgdir/usr/man" "$pkgdir/usr/share/"
+}