summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d20cf011f47a..620b92da026a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmake-git
pkgdesc = A make-like build utility based on Lua
- pkgver = 2.6.5.r2
+ pkgver = 2.6.5.r79
pkgrel = 1
url = http://xmake.io
arch = i686
@@ -8,7 +8,7 @@ pkgbase = xmake-git
license = Apache
makedepends = git
depends = ccache
- provides = xmake=2.6.5.r2
+ provides = xmake=2.6.5.r79
conflicts = xmake
source = git+https://github.com/xmake-io/xmake.git
source = git+https://github.com/xmake-io/xmake-core-lua-cjson.git
@@ -16,6 +16,7 @@ pkgbase = xmake-git
source = git+https://github.com/xmake-io/xmake-core-luajit.git
source = git+https://github.com/xmake-io/xmake-core-pdcurses.git
source = git+https://github.com/xmake-io/xmake-core-sv.git
+ source = git+https://github.com/xmake-io/xmake-core-lz4.git
source = git+https://github.com/tboox/tbox.git
sha256sums = SKIP
sha256sums = SKIP
@@ -24,5 +25,6 @@ pkgbase = xmake-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = xmake-git
diff --git a/PKGBUILD b/PKGBUILD
index 332bf2102bec..16cb676419f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Romain Chardiny <romain.chardiny@gmail.com>
_basename=xmake
pkgname=${_basename}-git
-pkgver=2.6.5.r40
+pkgver=2.6.5.r79
pkgrel=1
pkgdesc='A make-like build utility based on Lua'
arch=('i686' 'x86_64')
@@ -17,9 +17,10 @@ source=("git+https://github.com/xmake-io/xmake.git"
"git+https://github.com/xmake-io/xmake-core-luajit.git"
"git+https://github.com/xmake-io/xmake-core-pdcurses.git"
"git+https://github.com/xmake-io/xmake-core-sv.git"
+ "git+https://github.com/xmake-io/xmake-core-lz4.git"
"git+https://github.com/tboox/tbox.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver()
{
@@ -36,6 +37,7 @@ prepare()
git config submodule.core/src/luajit/luajit.url "$srcdir/xmake-core-luajit"
git config submodule.core/src/pdcurses/pdcurses.url "$srcdir/xmake-core-pdcurses"
git config submodule.core/src/sv/sv.url "$srcdir/xmake-core-sv"
+ git config submodule.core/src/lz4/lz4.url "$srcdir/xmake-core-lz4"
git config submodule.core/src/tbox/tbox.url "$srcdir/tbox"
git submodule update
}