summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8146343d7d99..939a905b42aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = xml-security-c
pkgdesc = C++ Implementation of W3C security standards for XML
- pkgver = 2.0.2
- pkgrel = 3
+ pkgver = 2.0.3
+ pkgrel = 1
url = http://santuario.apache.org/
arch = i686
arch = x86_64
license = Apache
depends = xerces-c
depends = xalan-c
- source = https://archive.apache.org/dist/santuario/c-library/xml-security-c-2.0.2.tar.bz2.asc
- source = https://archive.apache.org/dist/santuario/c-library/xml-security-c-2.0.2.tar.bz2
- source = xalan-c-1.12.patch
+ source = https://dlcdn.apache.org/santuario/c-library/xml-security-c-2.0.3.tar.bz2.asc
+ source = https://dlcdn.apache.org/santuario/c-library/xml-security-c-2.0.3.tar.bz2
validpgpkeys = DCAA15007BED9DE690CD9523378B845402277962
sha256sums = SKIP
- sha256sums = 39e963ab4da477b7bda058f06db37228664c68fe68902d86e334614dd06e046b
- sha256sums = fe009b1cadcbce62015229138ab9a8a07981264e802213d0888c281538748907
+ sha256sums = 803029f129005a9b453aa45f0b3e44c28b8f2ec5eb526c20c74f93995cf6da69
pkgname = xml-security-c
diff --git a/PKGBUILD b/PKGBUILD
index 1909f1c74a77..c5464829ca33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
# Maintainer: kevku <kevku@gmx.com>
pkgname='xml-security-c'
-pkgver='2.0.2'
-pkgrel='3'
+pkgver='2.0.3'
+pkgrel='1'
pkgdesc='C++ Implementation of W3C security standards for XML'
arch=('i686' 'x86_64')
url='http://santuario.apache.org/'
license=('Apache')
depends=('xerces-c' 'xalan-c')
-source=("https://archive.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.bz2.asc"
- "https://archive.apache.org/dist/santuario/c-library/$pkgname-$pkgver.tar.bz2"
- "xalan-c-1.12.patch")
+source=("https://dlcdn.apache.org/santuario/c-library/$pkgname-$pkgver.tar.bz2.asc"
+ "https://dlcdn.apache.org/santuario/c-library/$pkgname-$pkgver.tar.bz2")
sha256sums=('SKIP'
- '39e963ab4da477b7bda058f06db37228664c68fe68902d86e334614dd06e046b'
- 'fe009b1cadcbce62015229138ab9a8a07981264e802213d0888c281538748907')
+ '803029f129005a9b453aa45f0b3e44c28b8f2ec5eb526c20c74f93995cf6da69')
validpgpkeys=('DCAA15007BED9DE690CD9523378B845402277962')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/xalan-c-1.12.patch"
-}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \