summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de9dc057b27d..8d667b7b7d4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xml2rfc
pkgdesc = Generates RFCs and IETF drafts from document source in XML according to the DTD in RFC 2629
- pkgver = 2.5.2
+ pkgver = 2.24.0
pkgrel = 1
url = https://pypi.python.org/pypi/xml2rfc
arch = any
@@ -8,11 +8,8 @@ pkgbase = xml2rfc
depends = python
depends = python-lxml
depends = python-requests
- source = https://files.pythonhosted.org/packages/source/x/xml2rfc/xml2rfc-2.5.2.tar.gz
- source = https://files.pythonhosted.org/packages/source/x/xml2rfc/xml2rfc-2.5.2.tar.gz.asc
- validpgpkeys = 89F8DCE7EAE72F530905C6524E9B574B8FBB171A
- sha512sums = 492affeeef41d7cb1a58e012ba3f33448097f93d6d9c94435938115d5fe96577087babb9386ba222fd40069b311e898056df699776b3c5513556818873504136
- sha512sums = SKIP
+ source = https://files.pythonhosted.org/packages/39/02/046571ee27ad899066b691b9943ba2bd52fa03f8ed109ec0205f237cab81/xml2rfc-2.24.0.tar.gz
+ sha512sums = 9fcee3f7904d7f3e929d4c9a4048f739327dc75076e5896f232f08ae1d72eb9231dc21336620335c936024de2e1ca5521b1d132de428aa4c5b3c9868f524d43a
pkgname = xml2rfc
diff --git a/PKGBUILD b/PKGBUILD
index d601deef6f29..1fbb6411734d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,19 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xml2rfc
-pkgver=2.5.2
+pkgver=2.24.0
pkgrel=1
pkgdesc='Generates RFCs and IETF drafts from document source in XML according to the DTD in RFC 2629'
url='https://pypi.python.org/pypi/xml2rfc'
arch=(any)
depends=(python python-lxml python-requests)
license=(custom:BSD)
-source=(
- "https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
- "https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz.asc"
-)
-sha512sums=(
- '492affeeef41d7cb1a58e012ba3f33448097f93d6d9c94435938115d5fe96577087babb9386ba222fd40069b311e898056df699776b3c5513556818873504136'
- 'SKIP'
-)
+source=("https://files.pythonhosted.org/packages/39/02/046571ee27ad899066b691b9943ba2bd52fa03f8ed109ec0205f237cab81/xml2rfc-2.24.0.tar.gz")
+sha512sums=('9fcee3f7904d7f3e929d4c9a4048f739327dc75076e5896f232f08ae1d72eb9231dc21336620335c936024de2e1ca5521b1d132de428aa4c5b3c9868f524d43a')
validpgpkeys=('89F8DCE7EAE72F530905C6524E9B574B8FBB171A') # Henrik Levkowetz <FIRSTNAME@SURNAME.com>
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir"
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/xml2rfc/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/xml2rfc/LICENSE"
}