summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD26
-rw-r--r--patch-xmlada-config.in35
2 files changed, 52 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93bfbc84513f..df0a8cb4304b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,12 @@ license=('GPL')
depends=("gcc-ada")
source=(http://mirrors.cdn.adacore.com/art/949752df2432aed8d06c48d57cea71f38d0517cc
Makefile.archy
- generic_gpr.in)
+ generic_gpr.in
+ patch-xmlada-config.in)
md5sums=('98c96b8c6a877617ec4da3ef6a03288a'
'9784cefc4f5964b2469504f83957418f'
- 'cde06f485e180f4cc82bcdb450d36153')
+ 'cde06f485e180f4cc82bcdb450d36153'
+ '0b2eaa5ff3314a3dfcca66425d8f5d81')
GREP=grep
@@ -142,13 +144,6 @@ prepare()
# -exec ${PRINTF} ', "%s"' {} \;
-# ${SED} -e 's|@exec_prefix@|$${prefix}|' \
-# -e 's|@libdir@|$${exec_prefix}/lib|' \
-# -e 's|@includedir@|$${prefix}/include|' \
-# -e 's|@DEFAULT_LIBRARY_TYPE@|static|' \
-# -e 's|@PACKAGE_VERSION@|${PORTVERSION}|' \
-# ${WRKSRC}/xmlada-config.in > ${WRKSRC}/xmlada-config
-
${SED} -e '/^with/d' -e 's|@ZONE@|unicode|' \
-e "s|@FILES@|${FIND1}|" \
-e 's|@VERSION@|4.6.0.0|' ${FILESDIR}/generic_gpr.in \
@@ -183,6 +178,8 @@ prepare()
#
${REINPLACE_CMD} -i -e '/unicode/d' ${WRKSRC}/distrib/xmlada.gpr
+
+ patch -p0 -i ../patch-xmlada-config.in
}
@@ -190,7 +187,18 @@ prepare()
build()
{
cd $srcdir/$pkgname-gpl-$pkgver-src
+
./configure --prefix=/usr
+
+ ${SED} -e 's|@exec_prefix@|/usr|' \
+ -e 's|@libdir@|/usr/lib|' \
+ -e 's|@includedir@|/usr/include|' \
+ -e 's|@DEFAULT_LIBRARY_TYPE@|static|' \
+ -e 's|@PACKAGE_VERSION@|4.6.0.0|' \
+ ${WRKSRC}/xmlada-config.in > ${WRKSRC}/xmlada-config
+
+
+
make -f ../Makefile.archy all
}
diff --git a/patch-xmlada-config.in b/patch-xmlada-config.in
new file mode 100644
index 000000000000..792561bf85cc
--- /dev/null
+++ b/patch-xmlada-config.in
@@ -0,0 +1,35 @@
+*** xmlada-config.in-orig 2014-09-30 03:38:49.000000000 +1000
+--- xmlada-config.in 2015-07-26 07:04:02.197674720 +1000
+***************
+*** 8,15 ****
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@/xmlada
+
+- cflags_static=""
+- cflags_relocatable=""
+ mflags_static=""
+ mflags_relocatable=""
+ libs_relocatable=""
+--- 8,13 ----
+***************
+*** 17,26 ****
+ full_libs_relocatable=""
+ full_libs_static=""
+
+! for module in dom sax schema unicode input; do
+! cflags_static="${cflags_static} -I@includedir@/xmlada_${module}.static"
+! cflags_relocatble="${cflags_relocatable} -I@includedir@/xmlada_${module}.relocatable"
+
+ mflags_static="${mflags_static} -aI@includedir@/xmlada_${module}.static -aO@libdir@/xmlada_${module}.static"
+ mflags_relocatable="${mflags_relocatable} -aI@includedir@/xmlada_${module}.relocatable -aO@libdir@/xmlada_${module}.relocatable"
+ done
+--- 15,23 ----
+ full_libs_relocatable=""
+ full_libs_static=""
+
+! cflags=-I@includedir@/xmlada
+
++ for module in dom sax schema unicode input; do
+ mflags_static="${mflags_static} -aI@includedir@/xmlada_${module}.static -aO@libdir@/xmlada_${module}.static"
+ mflags_relocatable="${mflags_relocatable} -aI@includedir@/xmlada_${module}.relocatable -aO@libdir@/xmlada_${module}.relocatable"
+ done