summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--xmonad.install21
3 files changed, 14 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c35d4cb6698..3db8dcda079e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,8 +3,6 @@ pkgbase = xmonad-git
pkgver = v0.13.r7.g12a45b4
pkgrel = 1
url = http://xmonad.org/
- install = xmonad.install
- arch = i686
arch = x86_64
license = BSD
makedepends = gendesk
@@ -13,7 +11,7 @@ pkgbase = xmonad-git
depends = sh
depends = gmp
depends = haskell-x11>=1.8
- depends = haskell-x11<1.9
+ depends = haskell-x11<1.10
depends = haskell-mtl
depends = haskell-utf8-string>=0.3
depends = haskell-utf8-string<1.1
diff --git a/PKGBUILD b/PKGBUILD
index 8fb52d4fa0c9..de69822210d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Contributor: shild <shildv@gmail.com>
pkgname=xmonad-git
-pkgver=v0.13.r7.g12a45b4
+pkgver=v0.14.2.r5.g3d1720c
pkgrel=1
pkgdesc="Lightweight X11 tiled window manager written in Haskell"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://xmonad.org/"
license=('BSD')
depends=('ghc'
'sh'
'gmp'
- 'haskell-x11>=1.8' 'haskell-x11<1.9'
+ 'haskell-x11>=1.8' 'haskell-x11<1.10'
'haskell-mtl'
'haskell-utf8-string>=0.3' 'haskell-utf8-string<1.1'
'haskell-extensible-exceptions'
@@ -22,7 +22,6 @@ makedepends=('gendesk' 'git')
optdepends=('xorg-xmessage: for displaying visual error messages')
conflicts=('xmonad')
provides=('xmonad')
-install='xmonad.install'
source=('git://github.com/xmonad/xmonad.git'
'dynamic-compilation.patch'
'xmonad.svg')
@@ -56,17 +55,17 @@ build() {
package() {
cd "$srcdir"/${pkgname/-git}
- install -D -m744 register.sh $pkgdir/usr/share/haskell/${pkgname/-git}/register.sh
- install -m744 unregister.sh $pkgdir/usr/share/haskell/${pkgname/-git}/unregister.sh
- runhaskell Setup.lhs copy --destdir=$pkgdir
- install -D -m644 man/xmonad.1 $pkgdir/usr/share/man/man1/xmonad.1
- install -D -m644 LICENSE $pkgdir/usr/share/licenses/xmonad/LICENSE
- install -D -m644 $srcdir/xmonad.svg $pkgdir/usr/share/pixmaps/xmonad.svg
- install -D -m644 $srcdir/xmonad.desktop $pkgdir/usr/share/xsessions/xmonad.desktop
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname/-git}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname/-git}.sh"
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/$pkgname/html "$pkgdir/usr/share/doc/ghc/html/libraries/$pkgname"
+ runhaskell Setup.lhs copy --destdir="${pkgdir}"
- find "$pkgdir"/usr/lib -name "*.a" -delete
+ # Requires pandoc, regex-posix, Pretty and cabal
+ #runhaskell util/GenerateManpage.hs
+
+ install -Dm 644 man/xmonad.1 -t "${pkgdir}/usr/share/man/man1"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/xmonad"
+ install -Dm 644 "$srcdir/xmonad.svg" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm 644 "$srcdir/xmonad.desktop" -t "${pkgdir}/usr/share/xsessions"
}
diff --git a/xmonad.install b/xmonad.install
deleted file mode 100644
index aec6b6021cd6..000000000000
--- a/xmonad.install
+++ /dev/null
@@ -1,21 +0,0 @@
-HS_DIR=/usr/share/haskell/xmonad
-
-post_install() {
- ${HS_DIR}/register.sh
- echo "xmonad now has dynamic configuration via ~/.xmonad/xmonad.hs"
- echo "See http://haskell.org/haskellwiki/Xmonad/Config_archive for examples"
- echo "You have to rebuild this package after any change to the haskell deps"
-}
-
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-
-post_upgrade() {
- ${HS_DIR}/register.sh
- echo "You have to rebuild this package after any change to the haskell deps"
-}
-
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}