summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
-rw-r--r--no-donate.patch12
3 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 363d4991cbbe..47138d26be52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-pkgbase = xmr-stak-cpu-nicehash-git
+pkgbase = xmr-stak-cpu-git
pkgdesc = Monero CPU miner
pkgver = r246.5a03fc1
pkgrel = 1
- url = https://github.com/nicehash/xmr-stak-cpu
+ url = https://github.com/fireice-uk/xmr-stak
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
depends = libmicrohttpd
depends = openssl
- depends = hwloc
source = git+https://github.com/fireice-uk/xmr-stak-cpu.git
source = no-donate.patch
sha256sums = SKIP
- sha256sums = c973333e53efa4a94042f5b7c5d5d1b6995bb2cf261ac0ac7f735d93d795a6a6
+ sha256sums = b279c373afbce7cc8610c44f69a5e29a4b36969d131e2fd47229211a3903912a
-pkgname = xmr-stak-cpu-nicehash-git
+pkgname = xmr-stak-cpu-git
diff --git a/PKGBUILD b/PKGBUILD
index 79179816ac1c..e59c41b49628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-pkgname=xmr-stak-cpu-nicehash-git
+pkgname=xmr-stak-cpu-git
pkgver=r246.5a03fc1
pkgrel=1
pkgdesc="Monero CPU miner"
arch=('x86_64')
-url="https://github.com/nicehash/xmr-stak-cpu"
+url="https://github.com/fireice-uk/xmr-stak"
license=('GPL3')
makedepends=('git' 'cmake')
-depends=('libmicrohttpd' 'openssl' 'hwloc')
+depends=('libmicrohttpd' 'openssl')
source=('git+https://github.com/fireice-uk/xmr-stak-cpu.git'
'no-donate.patch')
sha256sums=('SKIP'
- 'c973333e53efa4a94042f5b7c5d5d1b6995bb2cf261ac0ac7f735d93d795a6a6')
+ 'b279c373afbce7cc8610c44f69a5e29a4b36969d131e2fd47229211a3903912a')
pkgver() {
- cd "$srcdir/xmr-stak-cpu"
+ cd "$srcdir/xmr-stak"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/xmr-stak-cpu"
+ cd "$srcdir/xmr-stak"
#patch -p1 -i ../../no-donate.patch
}
build() {
- cd "$srcdir/xmr-stak-cpu"
- cmake .
+ cd "$srcdir/xmr-stak"
+ cmake -DCUDA_ENABLE=off .
make
}
package() {
- install -D -m755 "$srcdir/xmr-stak-cpu/bin/xmr-stak-cpu" -t "$pkgdir/usr/bin/"
- install -D -m644 "$srcdir/xmr-stak-cpu/config.txt" "$pkgdir/etc/xmr-stak-cpu.json"
+ install -D -m755 "$srcdir/xmr-stak/bin/xmr-stak" -t "$pkgdir/usr/bin/"
+ install -D -m644 "$srcdir/xmr-stak/bin/libxmrstak_opencl_backend.so" -t "$pkgdir/usr/lib"
}
diff --git a/no-donate.patch b/no-donate.patch
index 439dcb02f2b1..cdc80b7a0ee5 100644
--- a/no-donate.patch
+++ b/no-donate.patch
@@ -1,9 +1,9 @@
-diff --git a/donate-level.h b/donate-level.h
-index 7b30212..02085c8 100644
---- a/donate-level.h
-+++ b/donate-level.h
-@@ -8,4 +8,4 @@
- * Switching is instant, and only happens after a successful connection, so you never loose any hashes.
+diff --git a/xmrstak/donate-level.hpp b/xmrstak/donate-level.hpp
+index 71b7962..53980d4 100644
+--- a/xmrstak/donate-level.hpp
++++ b/xmrstak/donate-level.hpp
+@@ -15,4 +15,4 @@
+ *
*/
-constexpr double fDevDonationLevel = 2.0 / 100.0;