summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md4
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c3dbec47109..31a1e774cd58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-bin
pkgdesc = Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level
- pkgver = 3.1.3
+ pkgver = 3.2.0
pkgrel = 1
url = https://github.com/xmrig/xmrig
install = xmrig.install
@@ -9,10 +9,10 @@ pkgbase = xmrig-bin
license = GPL
depends = glibc
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig/releases/download/v3.1.3/xmrig-3.1.3-xenial-x64.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig/v3.1.3/README.md
- md5sums = 37dd2724e117d28a1746a65ea151c98a
- md5sums = a4b1025bec3a89ff8cb4da85addddae1
+ source = https://github.com/xmrig/xmrig/releases/download/v3.2.0/xmrig-3.2.0-xenial-x64.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig/v3.2.0/README.md
+ md5sums = 2b34abd3ae6ef972cf93ce21f2271624
+ md5sums = 235bfe69c7da21e6df5e6a87742a2a11
pkgname = xmrig-bin
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 0a3cda0cf55f..45eb61bcd776 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+# v3.2.0
+- Added per pool option `coin` with single possible value `monero` for pools without algorithm negotiation, for upcoming Monero fork.
+- [#1183](https://github.com/xmrig/xmrig/issues/1183) Fixed compatibility with systemd.
+
# v3.1.3
- [#1180](https://github.com/xmrig/xmrig/issues/1180) Fixed possible duplicated shares after algorithm switching.
- Fixed wrong config file permissions after write (only gcc builds on recent Windows 10 affected).
diff --git a/PKGBUILD b/PKGBUILD
index 4aca9817f1d8..148fe71649a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
_pkgname=xmrig
pkgname=${_pkgname}-bin
-pkgver=3.1.3
+pkgver=3.2.0
pkgrel=1
pkgdesc="Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level"
arch=('x86_64')
@@ -13,8 +13,8 @@ install=${_pkgname}.install
changelog=CHANGELOG.md
source=("https://github.com/xmrig/xmrig/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-x64.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig/v${pkgver}/README.md")
-md5sums=('37dd2724e117d28a1746a65ea151c98a'
- 'a4b1025bec3a89ff8cb4da85addddae1')
+md5sums=('2b34abd3ae6ef972cf93ce21f2271624'
+ '235bfe69c7da21e6df5e6a87742a2a11')
package() {
cd "${_pkgname}-$pkgver"