summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
-rw-r--r--patch.patch23
3 files changed, 56 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 140a076dd4b4..7664663e4cbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Tue Jul 5 22:17:36 UTC 2016
pkgbase = xnp2
pkgdesc = X Neko Project II, a PC-9801 emulator
pkgver = 0.86
- pkgrel = 1
+ pkgrel = 3
url = http://www.nonakap.org/np2
- arch = i686
arch = x86_64
license = BSD
depends = gtk2
depends = sdl2_mixer
- source = http://www.nonakap.org/np2/release/xnp2-0.86.tar.bz2
+ depends = libsm
+ options = debug
+ source = https://www.nonakap.org/np2/release/xnp2-0.86.tar.bz2
source = patch.patch
- sha1sums = 02ade03afe672cc18068e75374eecc26ec53e32e
- sha1sums = f0056b23ae5fdc2b435f16a4879e495c45807375
+ sha256sums = e0b8c93f54682a4b3373907fd9ffe78094f95f7430dffc5038eccbcc4c3f78fd
+ sha256sums = 77b52b2832a9fc3ef8e71ccf85e5e04580247e80e4d973f46f71adc409df99c6
pkgname = xnp2
-
diff --git a/PKGBUILD b/PKGBUILD
index ecd5b68d9b57..ee6222723c09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,43 @@
pkgname=xnp2
pkgver=0.86
-pkgrel=1
+pkgrel=3
pkgdesc="X Neko Project II, a PC-9801 emulator"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.nonakap.org/np2'
license=('BSD')
-depends=('gtk2'
- 'sdl2_mixer'
- )
-source=("http://www.nonakap.org/np2/release/xnp2-${pkgver}.tar.bz2"
- 'patch.patch')
-sha1sums=('02ade03afe672cc18068e75374eecc26ec53e32e'
- 'f0056b23ae5fdc2b435f16a4879e495c45807375')
+depends=(
+ 'gtk2'
+ 'sdl2_mixer'
+ 'libsm'
+)
+source=(
+ "https://www.nonakap.org/np2/release/xnp2-${pkgver}.tar.bz2"
+ 'patch.patch'
+ )
+sha256sums=(
+ 'e0b8c93f54682a4b3373907fd9ffe78094f95f7430dffc5038eccbcc4c3f78fd'
+ '77b52b2832a9fc3ef8e71ccf85e5e04580247e80e4d973f46f71adc409df99c6'
+)
+options=('debug')
prepare() {
- cd "xnp2-${pkgver}"
- patch -p1 -i "${srcdir}/patch.patch"
-}
+ mkdir -p build
-build() {
- cd "xnp2-${pkgver}/x11"
- ./configure \
+ patch -d "xnp2-${pkgver}" -p1 -i "${srcdir}/patch.patch"
+
+ cd build
+ "../xnp2-${pkgver}/x11/configure" \
--prefix=/usr \
--enable-build-all \
+ --enable-ia32
#--enable-gtk3
- LC_ALL=C make
+}
+
+build() {
+ make -C build
}
package() {
- make -C "xnp2-${pkgver}/x11" DESTDIR="${pkgdir}/" install
+ make -C build DESTDIR="${pkgdir}/" install
}
diff --git a/patch.patch b/patch.patch
index 62659596664f..dd778d83c655 100644
--- a/patch.patch
+++ b/patch.patch
@@ -15,3 +15,26 @@
#ifndef ZeroMemory
#define ZeroMemory(d,n) memset((d), 0, (n))
+--- xnp2-0.86/x11/soundmng.c.old 2016-03-08 17:25:50.000000000 +0000
++++ xnp2-0.86/x11/soundmng.c 2021-11-04 00:00:00.000000000 +0000
+@@ -1179,8 +1179,9 @@
+ SNDBUF_FILLED_QUEUE_REMOVE_HEAD();
+ sndbuf_unlock();
+
+- SDL_MixAudio(stream,
++ SDL_MixAudioFormat(stream,
+ sndbuf->buf + (sndbuf->size - sndbuf->remain),
++ AUDIO_S16SYS,
+ sndbuf->remain, SDL_MIX_MAXVOLUME);
+ stream += sndbuf->remain;
+ len -= sndbuf->remain;
+@@ -1198,7 +1199,8 @@
+ sndbuf_unlock();
+ }
+
+- SDL_MixAudio(stream, sndbuf->buf + (sndbuf->size - sndbuf->remain),
++ SDL_MixAudioFormat(stream, sndbuf->buf + (sndbuf->size - sndbuf->remain),
++ AUDIO_S16SYS,
+ len, SDL_MIX_MAXVOLUME);
+ sndbuf->remain -= len;
+