summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
-rw-r--r--fix-alignment.patch37
-rw-r--r--patch.patch17
5 files changed, 53 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ab03f8c279e..140a076dd4b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 22:17:36 UTC 2016
pkgbase = xnp2
pkgdesc = X Neko Project II, a PC-9801 emulator
- pkgver = 20140607
- pkgrel = 2
- url = http://www.nonakap.org/np2/
+ pkgver = 0.86
+ pkgrel = 1
+ url = http://www.nonakap.org/np2
arch = i686
arch = x86_64
license = BSD
depends = gtk2
- depends = sdl_mixer
- source = http://www.nonakap.org/np2/xnp2-20140607.tar.bz2
- source = fix-alignment.patch
- md5sums = 4e2e01bc75479ef196b0056a78d31bd6
- md5sums = 8aa797282e965289d59b1ca0c7160435
+ depends = sdl2_mixer
+ source = http://www.nonakap.org/np2/release/xnp2-0.86.tar.bz2
+ source = patch.patch
+ sha1sums = 02ade03afe672cc18068e75374eecc26ec53e32e
+ sha1sums = f0056b23ae5fdc2b435f16a4879e495c45807375
pkgname = xnp2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d5a163ad2410
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!patch.patch
diff --git a/PKGBUILD b/PKGBUILD
index fe16872e9330..ecd5b68d9b57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
-# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Maintainer: Gustavo Alvarez Lopez <sl1pkn07@gmail.com>
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
# Contributor: Score_Under <seejay.11@gmail.com>
pkgname=xnp2
-pkgver=20140607
-pkgrel=2
+pkgver=0.86
+pkgrel=1
pkgdesc="X Neko Project II, a PC-9801 emulator"
arch=('i686' 'x86_64')
-url="http://www.nonakap.org/np2/"
+url='http://www.nonakap.org/np2'
license=('BSD')
-depends=('gtk2' 'sdl_mixer')
-source=("http://www.nonakap.org/np2/${pkgname}-${pkgver}.tar.bz2"
- "fix-alignment.patch")
-md5sums=('4e2e01bc75479ef196b0056a78d31bd6'
- '8aa797282e965289d59b1ca0c7160435')
+depends=('gtk2'
+ 'sdl2_mixer'
+ )
+source=("http://www.nonakap.org/np2/release/xnp2-${pkgver}.tar.bz2"
+ 'patch.patch')
+sha1sums=('02ade03afe672cc18068e75374eecc26ec53e32e'
+ 'f0056b23ae5fdc2b435f16a4879e495c45807375')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p0 < ../fix-alignment.patch
+ cd "xnp2-${pkgver}"
+ patch -p1 -i "${srcdir}/patch.patch"
}
build() {
- cd "$srcdir/$pkgname-$pkgver/x11"
- ./configure --prefix=/usr --enable-ia32
- make
+ cd "xnp2-${pkgver}/x11"
+ ./configure \
+ --prefix=/usr \
+ --enable-build-all \
+ #--enable-gtk3
+ LC_ALL=C make
}
package() {
- cd "$srcdir/$pkgname-$pkgver/x11"
- make DESTDIR="$pkgdir/" install
+ make -C "xnp2-${pkgver}/x11" DESTDIR="${pkgdir}/" install
}
-
-# vim:set ts=2 sts=2 sw=2 et:
diff --git a/fix-alignment.patch b/fix-alignment.patch
deleted file mode 100644
index 69ea170bbc0d..000000000000
--- a/fix-alignment.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- x11/gtk2/gtk_wrapper.c 2014-06-07 02:05:23.000000000 +0000
-+++ x11/gtk2/gtk_wrapper.c 2014-11-04 16:43:15.844542526 +0000
-@@ -124,14 +124,29 @@
- static gint orig_x, orig_y;
-
- static inline Bool
--XF86VidModeGetModeInfo(Display *d, int s, XF86VidModeModeInfo *info)
-+XF86VidModeGetModeInfo(Display *dpy, int scr, XF86VidModeModeInfo *info)
- {
-- XF86VidModeModeLine *line;
-+ // Slightly adapted from SDL_x11modes.c
-+ Bool retval;
-+ XF86VidModeModeLine l;
-
-- memset(info, 0, sizeof(*info));
-- line = (void *)((char *)info + sizeof(info->dotclock));
-+ memset(&l, 0, sizeof(l));
-+ retval = XF86VidModeGetModeLine(dpy, scr, &info->dotclock, &l);
-
-- return XF86VidModeGetModeLine(d, s, (int *)&info->dotclock, line);
-+ info->hdisplay = l.hdisplay;
-+ info->hsyncstart = l.hsyncstart;
-+ info->hsyncend = l.hsyncend;
-+ info->htotal = l.htotal;
-+ info->hskew = l.hskew;
-+ info->vdisplay = l.vdisplay;
-+ info->vsyncstart = l.vsyncstart;
-+ info->vsyncend = l.vsyncend;
-+ info->vtotal = l.vtotal;
-+ info->flags = l.flags;
-+ info->privsize = l.privsize;
-+ info->private = l.private;
-+
-+ return retval;
- }
-
- static int
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..62659596664f
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,17 @@
+--- xnp2-0.86/x11/compiler.h.old 2016-03-08 18:25:50.000000000 +0100
++++ xnp2-0.86/x11/compiler.h 2016-07-05 23:48:04.507937827 +0200
+@@ -117,12 +117,14 @@
+ #define MAX_PATH MAXPATHLEN
+ #endif
+
++#ifndef __cplusplus
+ #ifndef max
+ #define max(a,b) (((a) > (b)) ? (a) : (b))
+ #endif
+ #ifndef min
+ #define min(a,b) (((a) < (b)) ? (a) : (b))
+ #endif
++#endif /* __cplusplus */
+
+ #ifndef ZeroMemory
+ #define ZeroMemory(d,n) memset((d), 0, (n))