summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c08c2bec658..efe4501c9827 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xournalpp-git
pkgdesc = Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.
- pkgver = 1.1.1.r172.g932d46f18
+ pkgver = 1.2.1.r81.ge9ec03303
pkgrel = 1
url = https://github.com/xournalpp/xournalpp
arch = i686
@@ -11,8 +11,8 @@ pkgbase = xournalpp-git
makedepends = cmake
makedepends = help2man
makedepends = gtest
- depends = texlive-bin
depends = gtk3
+ depends = gtksourceview4
depends = poppler-glib
depends = libxml2
depends = portaudio
@@ -20,6 +20,7 @@ pkgbase = xournalpp-git
depends = lua53
depends = lua53-lgi
depends = libzip
+ optdepends = texlive-latexextra: LaTeX package
conflicts = xournalpp
source = xournalpp::git+https://github.com/xournalpp/xournalpp.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 24158b9281e2..f1ec40686379 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
_pkgname="xournalpp"
pkgname="${_pkgname}-git"
-pkgver=1.1.1.r172.g932d46f18
+pkgver=1.2.1.r81.ge9ec03303
pkgrel=1
pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/xournalpp/xournalpp"
license=('GPL2')
+depends=('gtk3' 'gtksourceview4' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua53' 'lua53-lgi' 'libzip')
makedepends=('git' 'cmake' 'help2man' 'gtest')
-depends=('texlive-bin' 'gtk3' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua53' 'lua53-lgi' 'libzip')
+optdepends=('texlive-latexextra: LaTeX package')
conflicts=('xournalpp')
source=("${_pkgname}::git+https://github.com/xournalpp/xournalpp.git")
sha256sums=('SKIP')
@@ -30,8 +31,6 @@ build() {
cd "${srcdir}/${_pkgname}/build"
cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DENABLE_GTEST=ON ..
- cmake --build . --target pot
- cmake --build . --target translations
cmake --build .
cmake --build . --target test-units
}