summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--giflib.patch29
3 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e631a1188480..62afcfa1d132 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xplanet-svn
pkgdesc = Renders an image of the earth into the X root window
- pkgver = 20190922.213
- pkgrel = 2
+ pkgver = 20191013.220
+ pkgrel = 1
url = http://xplanet.sourceforge.net/
arch = i686
arch = x86_64
@@ -15,9 +15,7 @@ pkgbase = xplanet-svn
provides = xplanet
conflicts = xplanet
source = xplanet::svn://svn.code.sf.net/p/xplanet/code/trunk
- source = giflib.patch
sha256sums = SKIP
- sha256sums = c9abf31bf242d7c0940e8fbc5b64714c12edd4b995aba1ebe776ddc0c5bf019a
pkgname = xplanet-svn
diff --git a/PKGBUILD b/PKGBUILD
index fef2468b27c1..bf2275931efb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,16 @@
pkgname=xplanet-svn
_pkgname=xplanet
-pkgver=20190922.213
-pkgrel=2
+pkgver=20191013.220
+pkgrel=1
pkgdesc='Renders an image of the earth into the X root window'
url='http://xplanet.sourceforge.net/'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL2')
makedepends=('subversion')
depends=('pango' 'giflib' 'libtiff' 'libxss')
-source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk"
- "giflib.patch")
-sha256sums=('SKIP'
- 'c9abf31bf242d7c0940e8fbc5b64714c12edd4b995aba1ebe776ddc0c5bf019a')
+source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk")
+sha256sums=('SKIP')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -26,7 +24,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- patch -p1 <"${srcdir}/giflib.patch"
sed 's: -I`$FREETYPE_CONFIG --prefix`/include::g' -i acinclude.m4
aclocal && autoconf && automake --add-missing
}
diff --git a/giflib.patch b/giflib.patch
deleted file mode 100644
index e4881ca741fe..000000000000
--- a/giflib.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- xplanet/src/libimage/gif.c.orig 2015-07-07 11:38:14.926692910 +0200
-+++ xplanet/src/libimage/gif.c 2015-07-07 12:10:07.745836346 +0200
-@@ -179,7 +179,7 @@
- }
- }
-
-- if (DGifCloseFile(GifFile) == GIF_ERROR) {
-+ if (DGifCloseFile(GifFile, NULL) == GIF_ERROR) {
- return(0);
- }
-
-@@ -493,7 +493,7 @@
- static void QuitGifError(GifFileType *GifFile)
- {
- fprintf(stderr, "Error writing GIF file\n");
-- if (GifFile != NULL) EGifCloseFile(GifFile);
-+ if (GifFile != NULL) EGifCloseFile(GifFile, NULL);
- }
-
- int
-@@ -589,7 +589,7 @@
- Ptr += width;
- }
-
-- if (EGifCloseFile(GifFile) == GIF_ERROR)
-+ if (EGifCloseFile(GifFile, NULL) == GIF_ERROR)
-
- {
- QuitGifError(GifFile);