summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be7956106477..559bb5115a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = xplr-git
pkgdesc = A hackable, minimal, fast TUI file explorer (git)
- pkgver = 0.15.2.r4.gc5f6095
+ pkgver = 0.20.2.r21.g6595e2e
pkgrel = 1
url = https://github.com/sayanarijit/xplr
arch = x86_64
license = MIT
- makedepends = rust
+ makedepends = cargo
makedepends = git
depends = gcc-libs
depends = hicolor-icon-theme
provides = xplr
conflicts = xplr
+ options = !lto
source = git+https://github.com/sayanarijit/xplr
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aaf480932090..c12f60e4f490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
# https://github.com/orhun/pkgbuilds
pkgname=xplr-git
-pkgver=0.15.2.r4.gc5f6095
+pkgver=0.20.2.r21.g6595e2e
pkgrel=1
pkgdesc="A hackable, minimal, fast TUI file explorer (git)"
arch=('x86_64')
url="https://github.com/sayanarijit/xplr"
license=('MIT')
depends=('gcc-libs' 'hicolor-icon-theme')
-makedepends=('rust' 'git')
+makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
sha512sums=('SKIP')
+options=('!lto')
pkgver() {
cd "${pkgname%-git}"
@@ -22,7 +23,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- cargo fetch --locked
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {