summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--xerces-containing-node.patch55
3 files changed, 6 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51ae2fbcf8d4..e09598569d26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = xqilla
pkgdesc = An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C.
- pkgver = 2.3.3
+ pkgver = 2.3.4
pkgrel = 1
url = http://xqilla.sourceforge.net/
arch = x86_64
license = GPL3
depends = xerces-c
depends = icu
- source = https://downloads.sourceforge.net/project/xqilla/XQilla-2.3.3.tar.gz
- source = xerces-containing-node.patch
- sha256sums = 8f76b9b4f966f315acc2a8e104e426d8a76ba4ea3441b0ecfdd1e39195674fd6
- sha256sums = 36ffb2dff579e5610ca3be2a962942433127b24a78ca454647059d6d54b8e014
+ source = https://downloads.sourceforge.net/project/xqilla/XQilla-2.3.4.tar.gz
+ sha256sums = adfd4df011fcda08be3f51771006da23e852bac81e2fe63159beddc3633b3f55
pkgname = xqilla
diff --git a/PKGBUILD b/PKGBUILD
index 631d0e0dcd4a..c28c7a7583b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Brendan Abolivier <brendan@cozycloud.cc>
pkgname=xqilla
-pkgver=2.3.3
+pkgver=2.3.4
pkgrel=1
pkgdesc="An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C."
arch=("x86_64")
url="http://xqilla.sourceforge.net/"
license=("GPL3")
depends=("xerces-c" "icu")
-source=("https://downloads.sourceforge.net/project/xqilla/XQilla-${pkgver}.tar.gz"
- "xerces-containing-node.patch")
-sha256sums=('8f76b9b4f966f315acc2a8e104e426d8a76ba4ea3441b0ecfdd1e39195674fd6'
- '36ffb2dff579e5610ca3be2a962942433127b24a78ca454647059d6d54b8e014')
+source=("https://downloads.sourceforge.net/project/xqilla/XQilla-${pkgver}.tar.gz")
+sha256sums=('adfd4df011fcda08be3f51771006da23e852bac81e2fe63159beddc3633b3f55')
prepare() {
cd "XQilla-${pkgver}"
-
- # Apply patch from Homebrew to make XQilla compatible with Xerces-C 3.2.
- # See: https://sourceforge.net/p/xqilla/bugs/48/
- patch -p1 < "${srcdir}/xerces-containing-node.patch"
}
build() {
diff --git a/xerces-containing-node.patch b/xerces-containing-node.patch
deleted file mode 100644
index 6ab3a5b104e4..000000000000
--- a/xerces-containing-node.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/src/dom-api/impl/XPathDocumentImpl.cpp 2017-09-03 19:24:35 UTC
-+++ b/src/dom-api/impl/XPathDocumentImpl.cpp
-@@ -62,7 +62,11 @@ DOMNode *XPathDocumentImpl::insertBefore
- if (thisNodeImpl->isReadOnly())
- throw DOMException(DOMException::NO_MODIFICATION_ALLOWED_ERR, 0, getMemoryManager());
-
-+#if _XERCES_VERSION >= 30200
-+ DOMNode* thisNode = fParent.fContainingNode;
-+#else
- DOMNode* thisNode = castToNode(&fParent);
-+#endif
- if (newChild->getOwnerDocument() != thisNode)
- throw DOMException(DOMException::WRONG_DOCUMENT_ERR, 0, getMemoryManager());
-
---- a/src/dom-api/impl/XPathNamespaceImpl.cpp 2017-09-03 20:26:37 UTC
-+++ b/src/dom-api/impl/XPathNamespaceImpl.cpp
-@@ -33,7 +33,11 @@ XERCES_CPP_NAMESPACE_USE;
-
- XPathNamespaceImpl::XPathNamespaceImpl(const XMLCh* const nsPrefix,
- const XMLCh* const nsUri, DOMElement *owner, DOMDocument *docOwner)
-+#if _XERCES_VERSION >= 30200
-+ : fNode(this, docOwner)
-+#else
- : fNode(docOwner)
-+#endif
- {
- DOMNodeImpl *argImpl = castToNodeImpl(this);
-
-@@ -54,7 +58,13 @@ XPathNamespaceImpl::XPathNamespaceImpl(c
- }
-
- XPathNamespaceImpl::XPathNamespaceImpl(const XPathNamespaceImpl &other)
-- : fNode(other.fNode), uri(other.uri), prefix(other.prefix)
-+#if _XERCES_VERSION >= 30200
-+ : fNode(this, other.fNode),
-+#else
-+ : fNode(other.fNode),
-+
-+#endif
-+ uri(other.uri), prefix(other.prefix)
- {
- }
-
-@@ -196,7 +206,11 @@ short XPathNamespaceImpl::com
-
- //if it is a custom node and bigger than us we must ask it for the order
- if(otherType > DOMXPathNamespace::XPATH_NAMESPACE_NODE) {
-+#if _XERCES_VERSION >= 30200
-+ DOMNodeImpl tmp(const_cast<XPathNamespaceImpl *>(this), 0);
-+#else
- DOMNodeImpl tmp(0);
-+#endif
- #if _XERCES_VERSION >= 30000
- return tmp.reverseTreeOrderBitPattern(other->compareDocumentPosition(this));
- #else