summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8778661be205
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xrestop-git
+ pkgdesc = Uses the X-Resource extension to provide 'top' like statistics
+ pkgver = 0.4r29.1dd66f8
+ pkgrel = 1
+ url = http://freedesktop.org/wiki/Software/xrestop
+ arch = x86_64
+ license = GPL
+ depends = libxres
+ depends = ncurses
+ source = git+https://gitlab.freedesktop.org/xorg/app/xrestop
+ md5sums = SKIP
+
+pkgname = xrestop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6de028b4ac12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: William Rea <sillywilly@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=xrestop-git
+pkgver=0.4r29.1dd66f8
+pkgrel=1
+pkgdesc="Uses the X-Resource extension to provide 'top' like statistics"
+arch=('x86_64')
+url="http://freedesktop.org/wiki/Software/xrestop"
+license=('GPL')
+depends=('libxres' 'ncurses')
+source=(git+https://gitlab.freedesktop.org/xorg/app/xrestop)
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "0.4r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd ${pkgname%-git}
+ ./autogen.sh --prefix=/usr --mandir=/usr/share/man
+ #./configure
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir" install
+}