summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--readme.install6
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d82cee84469..20637566fbc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Oct 24 21:22:36 UTC 2018
+# Thu Oct 25 19:29:31 UTC 2018
pkgbase = xscreensaver-aerial
pkgdesc = xscreensaver hack that randomly selects one of the Apple TV4 HD aerial movies
- pkgver = 1.08
+ pkgver = 1.09
pkgrel = 1
url = https://github.com/graysky2/xscreensaver-aerial
install = readme.install
@@ -10,9 +10,10 @@ pkgbase = xscreensaver-aerial
license = MIT
depends = xscreensaver
depends = mpv
+ depends = wget
optdepends = xscreensaver-aerial-videos: pre-downloaded videos to save bandwidth
- source = https://github.com/graysky2/xscreensaver-aerial/archive/v1.08.tar.gz
- sha256sums = 057cb1a11ce7d9e3277bbd090245b87ca870d97acc4c570de5fc55f079d00105
+ source = https://github.com/graysky2/xscreensaver-aerial/archive/v1.09.tar.gz
+ sha256sums = 3089fd2a739d784bef41f93301d4b4ce0fcf4e3f88a2a7a7cea18fe04f581ca7
pkgname = xscreensaver-aerial
diff --git a/PKGBUILD b/PKGBUILD
index b1918c2c4e40..cf8090a4fcce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
pkgname='xscreensaver-aerial'
-pkgver=1.08
+pkgver=1.09
pkgrel=1
arch=('any')
url="https://github.com/graysky2/xscreensaver-aerial"
license=('MIT')
pkgdesc='xscreensaver hack that randomly selects one of the Apple TV4 HD aerial movies'
-depends=('xscreensaver' 'mpv')
+depends=('xscreensaver' 'mpv' 'wget')
optdepends=('xscreensaver-aerial-videos: pre-downloaded videos to save bandwidth')
install=readme.install
source=("https://github.com/graysky2/xscreensaver-aerial/archive/v$pkgver.tar.gz")
-sha256sums=('057cb1a11ce7d9e3277bbd090245b87ca870d97acc4c570de5fc55f079d00105')
+sha256sums=('3089fd2a739d784bef41f93301d4b4ce0fcf4e3f88a2a7a7cea18fe04f581ca7')
package() {
cd "$pkgname-$pkgver"
- install -Dm755 atv4.sh "${pkgdir}/usr/lib/xscreensaver/atv4"
+ install -Dm755 atv4-1080.sh "${pkgdir}/usr/lib/xscreensaver/atv4-1080"
+ install -Dm755 atv4-4k.sh "${pkgdir}/usr/lib/xscreensaver/atv4-4k"
install -Dm644 MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/readme.install b/readme.install
index 5eb817864d0a..750d638dee77 100644
--- a/readme.install
+++ b/readme.install
@@ -2,7 +2,8 @@ post_install() {
echo '------------------------------------------------------------------------------------'
echo ' You must edit ~/.xscreensaver to add support for this screensaver'
echo ' Find the line "programs:" and simply add the following below it:'
- echo ' "ATV4" atv4 \n\'
+ echo ' "ATV4-1080" atv4-1080 \n\'
+ echo ' "ATV4-4k" atv4-4k \n\'
echo '------------------------------------------------------------------------------------'
}
@@ -13,7 +14,8 @@ post_upgrade() {
echo ' You must manually delete your day and night databases or wait for all videos to'
echo ' cycle for the rebuild. New videos will be unavailable until either of these happen.'
echo
- echo ' Hint: the databases reside in $XDG_CONFIG_HOME/.atv4-{day,night}'
+ echo ' Hint: the databases reside in $XDG_CONFIG_HOME/.atv4-{day,night} for 1080 and'
+ echo ' in $XDG_CONFIG_HOME/.atv4-{day,night}-4k for 4k.'
echo '------------------------------------------------------------------------------------'
fi
}