summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--Makefile.diff39
-rw-r--r--PKGBUILD26
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca4aaa182614
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xtris
+ pkgdesc = Multiplayer Tetris for X
+ pkgver = 1.15
+ pkgrel = 3
+ url = http://www.iagora.com/~espel/xtris/xtris.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ source = http://ftp.uni-erlangen.de/mirrors/gentoo/distfiles/xtris-1.15.tar.gz
+ source = Makefile.diff
+ md5sums = c63be31895feca9f929b57b67b779ced
+ md5sums = 4085d4fab44f52fd521818023d36251e
+
+pkgname = xtris
+
diff --git a/Makefile.diff b/Makefile.diff
new file mode 100644
index 000000000000..87c3d1cd8030
--- /dev/null
+++ b/Makefile.diff
@@ -0,0 +1,39 @@
+--- Makefile 1997-12-14 19:43:35.000000000 +0100
++++ Makefile 2008-08-13 00:31:58.000000000 +0200
+@@ -10,14 +10,16 @@
+ # change this to your favorite ANSI C compiler
+ CC = gcc
+
++DESTDIR :=
++
+ # change this to the directory where you want the xtris binaries installed
+-BINDIR = /usr/local/bin
++BINDIR = $(DESTDIR)/usr/bin
+
+ # change this to the directory where you want the xtris manpages installed
+-MANDIR = /usr/local/man
++MANDIR = $(DESTDIR)/usr/share/man
+
+ # change according to taste and local custom...
+-CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__
++# CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__
+
+ # on Solaris and similar systems, you'll need to uncomment this:
+ # EXTRALIBS = -lnsl -lsocket
+@@ -48,12 +50,11 @@
+
+ install: xtris xtserv xtbot
+ -strip xtris xtserv xtbot
+- -mkdir $(BINDIR) 2>/dev/null
+- -mkdir $(MANDIR) 2>/dev/null
+- -mkdir $(MANDIR)/man6 2>/dev/null
+- cp xtris xtserv xtbot $(BINDIR)
++ install -m 755 -d $(BINDIR)
++ install -m 755 -d $(MANDIR)/man6
++ cp xtris xtserv xtbot $(BINDIR)/
+ chmod 755 $(BINDIR)/xtris $(BINDIR)/xtserv $(BINDIR)/xtbot
+- cp xtris.6 xtserv.6 xtbot.6 $(MANDIR)/man6
++ cp xtris.6 xtserv.6 xtbot.6 $(MANDIR)/man6/
+ chmod 644 $(MANDIR)/man6/xtris.6 $(MANDIR)/man6/xtserv.6 $(MANDIR)/man6/xtbot.6
+
+ tar:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac3fb3ac2094
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ajs124 < aur AT ajs124 DOT de >
+# Contributor: SiD/sidious <miste78@web.de>
+
+pkgname=xtris
+pkgver=1.15
+pkgrel=3
+pkgdesc="Multiplayer Tetris for X"
+arch=('i686' 'x86_64')
+url="http://www.iagora.com/~espel/xtris/xtris.html"
+license=('GPL')
+depends=('libx11')
+source=("http://ftp.uni-erlangen.de/mirrors/gentoo/distfiles/xtris-1.15.tar.gz" \
+ "Makefile.diff")
+md5sums=('c63be31895feca9f929b57b67b779ced' \
+ '4085d4fab44f52fd521818023d36251e')
+
+build() {
+ cd "$srcdir/$pkgname"
+ patch -p0 < ../Makefile.diff
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}