summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3578786e410e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xts-windows10-theme
+ pkgdesc = Windows 10 themes for xfce4-theme switcher.
+ pkgver = 0.1
+ pkgrel = 0
+ url = https://gitlab.com/linux-stuffs/xts-themes
+ arch = any
+ groups = xfce4-goodies
+ license = combined licenses
+ depends = xfce4-theme-switcher
+ depends = xfce4-whiskermenu-plugin
+ depends = gtk-engine-murrine
+ optdepends = plank
+ optdepends = conky-manager
+ provides = xts-windows10-theme
+ conflicts = xts-windows10-theme
+ options = !strip
+ source = https://gitlab.com/linux-stuffs/xts-themes/raw/master/xts-windows10-theme/distrib/xts-windows10-theme-0.1-0.tar.gz
+ sha256sums = SKIP
+
+pkgname = xts-windows10-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d8bcd6b8ab3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Pavel Sibal <entexsoft@gmail.com>
+pkgname=xts-windows10-theme
+pkgver=0.1
+pkgrel=0
+pkgdesc="Windows 10 themes for xfce4-theme switcher."
+arch=('any')
+url="https://gitlab.com/linux-stuffs/xts-themes"
+license=('combined licenses')
+groups=('xfce4-goodies')
+
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+depends=('xfce4-theme-switcher' 'xfce4-whiskermenu-plugin' 'gtk-engine-murrine')
+optdepends=('plank' 'conky-manager')
+options=('!strip')
+
+source=('https://gitlab.com/linux-stuffs/xts-themes/raw/master/xts-windows10-theme/distrib/xts-windows10-theme-0.1-0.tar.gz')
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr
+ make install DESTDIR="${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp --no-preserve=ownership "${pkgdir}/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}