summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch35
-rw-r--r--PKGBUILD37
-rw-r--r--gettid.patch17
-rw-r--r--sysctl.patch15
5 files changed, 106 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 890990b24b0e..d55301fe439c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xulrunner
pkgdesc = Mozilla Runtime Environment
pkgver = 41.0.2
- pkgrel = 15
+ pkgrel = 18
url = http://wiki.mozilla.org/XUL:Xul_Runner
arch = x86_64
license = MPL
@@ -30,6 +30,8 @@ pkgbase = xulrunner
depends = libvpx
depends = icu
depends = python2
+ depends = libpng-apng
+ depends = alsa-lib
replaces = xulrunner-oss
options = !emptydirs
options = !makeflags
@@ -38,22 +40,28 @@ pkgbase = xulrunner
source = mozconfig
source = freetype261.patch
source = 0001-Bug-1233963-Work-around-recent-GNU-gold-behavior-wit.patch
+ source = 0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
source = Bug-1269171.patch
source = LFS_graphite2_harfbuzz.patch
source = mozilla-pkgconfig.patch
source = shared-libs.patch
source = sed43.patch
source = gcc6.diff
+ source = sysctl.patch
+ source = gettid.patch
sha256sums = f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864
sha256sums = 8ab57ae3ba4660a721cdb210babee02488b670d9af9fdecf5da3b832d77e342b
sha256sums = 3aea9a83bf304da5525f34a911712cf42f8ded1c8b6becf0a2cf8a4b4f7facd6
sha256sums = 13a27a385fab88938ac7417f1e7ca7225ec6b88840bafe67e0f5642e5446554a
+ sha256sums = 815cf186cd697ee3277d7b661285f13b5db65a582379df78696d7502fb09b520
sha256sums = bd78da5d5319c8eb6a9195c3bd35bf919f9a9c030d69890f42e96171e32be60f
sha256sums = afcd7d3f6113b0f9ead0cb1b47b3fccedadce56a16b4406c439411864bd11863
sha256sums = 1aa9ebe67542a2b8c28905d070829ada5b29438c6a7961f2b0cdd6b92d8b9f5c
sha256sums = 59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40
sha256sums = e9b7199b57fa07e440d37db0cc3cf52aa1c1fd7d5e8b31db14e511d77b5ce327
sha256sums = 0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098
+ sha256sums = ef0571447499fbf64e5c4723760c73f86b9e10b80df33e6a2979b6b02e3ae68e
+ sha256sums = b5d5f8a94ff490fe3e9d26f339e2a40d2e4c349d03e9d38f08ae16eddc7f45fe
pkgname = xulrunner
diff --git a/0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch b/0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
new file mode 100644
index 000000000000..b492cd3b73cd
--- /dev/null
+++ b/0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
@@ -0,0 +1,35 @@
+# HG changeset patch
+# User Michał Górny <mgorny@gentoo.org>
+
+Include sys/sysmacros.h for major(), minor() on Linux
+
+Include sys/sysmacros.h explicitly as that will be required by future
+glibc versions to expose major() and minor() macros.
+
+Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1329798
+
+diff --git a/config/system-headers b/config/system-headers
+index 60788e788..984e86933 100644
+--- a/config/system-headers
++++ b/config/system-headers
+@@ -1055,6 +1055,7 @@ sys/statvfs.h
+ sys/syscall.h
+ sys/sysctl.h
+ sys/sysinfo.h
++sys/sysmacros.h
+ sys/sysmp.h
+ sys/syssgi.h
+ sys/system_properties.h
+diff --git a/xpcom/io/nsLocalFileUnix.cpp b/xpcom/io/nsLocalFileUnix.cpp
+index 6f13e2a7d..6149aaeac 100644
+--- a/xpcom/io/nsLocalFileUnix.cpp
++++ b/xpcom/io/nsLocalFileUnix.cpp
+@@ -26,6 +26,7 @@
+ #define USE_LINUX_QUOTACTL
+ #include <sys/mount.h>
+ #include <sys/quota.h>
++#include <sys/sysmacros.h>
+ #ifndef BLOCK_SIZE
+ #define BLOCK_SIZE 1024 /* kernel block size */
+ #endif
+
diff --git a/PKGBUILD b/PKGBUILD
index 40904c722bcf..8c53bb2937f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,36 +5,41 @@
pkgname=xulrunner
pkgver=41.0.2
-pkgrel=15
+pkgrel=18
pkgdesc="Mozilla Runtime Environment"
arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2')
+depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2' 'libpng-apng' 'alsa-lib')
makedepends=('gcc6' 'zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'gconf' 'autoconf2.13' 'gst-plugins-base-libs')
url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.xz
mozconfig
freetype261.patch
0001-Bug-1233963-Work-around-recent-GNU-gold-behavior-wit.patch
+ 0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
Bug-1269171.patch
LFS_graphite2_harfbuzz.patch
mozilla-pkgconfig.patch
shared-libs.patch
sed43.patch
- gcc6.diff)
+ gcc6.diff
+ sysctl.patch
+ gettid.patch)
options=('!emptydirs' '!makeflags' 'staticlibs')
replaces=('xulrunner-oss')
sha256sums=('f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864'
'8ab57ae3ba4660a721cdb210babee02488b670d9af9fdecf5da3b832d77e342b'
'3aea9a83bf304da5525f34a911712cf42f8ded1c8b6becf0a2cf8a4b4f7facd6'
'13a27a385fab88938ac7417f1e7ca7225ec6b88840bafe67e0f5642e5446554a'
+ '815cf186cd697ee3277d7b661285f13b5db65a582379df78696d7502fb09b520'
'bd78da5d5319c8eb6a9195c3bd35bf919f9a9c030d69890f42e96171e32be60f'
'afcd7d3f6113b0f9ead0cb1b47b3fccedadce56a16b4406c439411864bd11863'
'1aa9ebe67542a2b8c28905d070829ada5b29438c6a7961f2b0cdd6b92d8b9f5c'
'59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40'
'e9b7199b57fa07e440d37db0cc3cf52aa1c1fd7d5e8b31db14e511d77b5ce327'
- '0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098')
-
+ '0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098'
+ 'ef0571447499fbf64e5c4723760c73f86b9e10b80df33e6a2979b6b02e3ae68e'
+ 'b5d5f8a94ff490fe3e9d26f339e2a40d2e4c349d03e9d38f08ae16eddc7f45fe')
prepare() {
cd "$srcdir/mozilla-release"
cp "$srcdir/mozconfig" .mozconfig
@@ -53,6 +58,13 @@ prepare() {
patch -Np1 -i ../gcc6.diff
patch -Np1 -i ../Bug-1269171.patch
+ # Fix for Bug 1329798 "Use of major & minor macros without including sys/sysmacros.h"
+ patch -Np1 -i ../0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
+
+ # Fix for removing sys/sysctl.h and declaration of gettid
+ patch -Np1 -i ../sysctl.patch
+ patch -Np1 -i ../gettid.patch
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=847568
patch -Np1 -i ../LFS_graphite2_harfbuzz.patch
sed -i -e "s|lcrmf|lm|g" configure.in
@@ -66,8 +78,8 @@ prepare() {
# WebRTC build tries to execute "python" and expects Python 2
# Workaround taken from chromium PKGBUILD
- mkdir "$srcdir/python2-path"
- ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ mkdir -p "$srcdir/python2-path"
+ ln -sf /usr/bin/python2 "$srcdir/python2-path/python"
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
@@ -81,11 +93,22 @@ build() {
export LDFLAGS="$LDFALGS -Wl,-rpath,/usr/lib/xulrunner-$pkgver"
export PYTHON="/usr/bin/python2"
+ export CFLAGS="${CFLAGS/-fstack-clash-protection/}"
+ export CFLAGS="${CFLAGS/-fcf-protection/}"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/}"
+ export CXXFLAGS="${CXXFLAGS/-fcf-protection/}"
+
make -j1 -f client.mk build
}
package() {
cd "$srcdir/mozilla-release"
+
+ export CFLAGS="${CFLAGS/-fstack-clash-protection/}"
+ export CFLAGS="${CFLAGS/-fcf-protection/}"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/}"
+ export CXXFLAGS="${CXXFLAGS/-fcf-protection/}"
+
make -j1 -f client.mk DESTDIR="$pkgdir" install
# Use system-provided dictionaries
diff --git a/gettid.patch b/gettid.patch
new file mode 100644
index 000000000000..d86b2c2959ed
--- /dev/null
+++ b/gettid.patch
@@ -0,0 +1,17 @@
+--- src/tools/profiler/platform-linux-lul.h 2015-10-15 04:41:22.000000000 +0700
++++ work/tools/profiler/platform-linux-lul.h 2020-09-03 22:46:43.264756553 +0700
+@@ -21,10 +21,10 @@
+ #if defined(__GLIBC__)
+ #include <unistd.h>
+ #include <sys/syscall.h>
+-static inline pid_t gettid()
+-{
+- return (pid_t) syscall(SYS_gettid);
+-}
++// static inline pid_t gettid()
++// {
++// return (pid_t) syscall(SYS_gettid);
++// }
+ #endif
+
+ // A singleton instance of the library.
diff --git a/sysctl.patch b/sysctl.patch
new file mode 100644
index 000000000000..14ac556cc37f
--- /dev/null
+++ b/sysctl.patch
@@ -0,0 +1,15 @@
+--- org/memory/mozjemalloc/jemalloc.c 2015-10-15 04:41:05.000000000 +0700
++++ work/memory/mozjemalloc/jemalloc.c 2020-09-03 22:47:42.138024901 +0700
+@@ -325,9 +325,9 @@
+ #endif
+ #include <sys/time.h>
+ #include <sys/types.h>
+-#if !defined(MOZ_MEMORY_SOLARIS) && !defined(MOZ_MEMORY_ANDROID)
+-#include <sys/sysctl.h>
+-#endif
++// #if !defined(MOZ_MEMORY_SOLARIS) && !defined(MOZ_MEMORY_ANDROID)
++// #include <sys/sysctl.h>
++// #endif
+ #include <sys/uio.h>
+ #ifndef MOZ_MEMORY
+ #include <sys/ktrace.h> /* Must come after several other sys/ includes. */