summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
-rw-r--r--xyscan-3.3.3-docs.patch31
3 files changed, 20 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9af002bfda7d..d4010997bc59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = xyscan
pkgdesc = Tool to extract data points from graphical plots
- pkgver = 3.3.3
- pkgrel = 2
- url = http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://rhig.physics.yale.edu/~ullrich/software/xyscan/
install = xyscan.install
arch = i686
arch = x86_64
license = GPL
depends = qt5-multimedia>=5.2.0
- source = http://rhig.physics.yale.edu/~ullrich/software/xyscan/Distributions/3.33/xyscan-3.33-src.tar.gz
- source = xyscan-3.3.3-docs.patch
+ depends = poppler-qt5
+ source = http://rhig.physics.yale.edu/~ullrich/software/xyscan/Distributions/4.00/xyscan-4.00-src.tar.gz
source = xyscan.desktop
- md5sums = d236ee95950edbf0dfef895ea59aafcd
- md5sums = 22093f1c22b73f95de1cbfee14d74dc4
+ md5sums = 57000c8e4192c9185647ffb37fad6eca
md5sums = 2df01c952f8425d05e0d138778ca5be9
pkgname = xyscan
diff --git a/PKGBUILD b/PKGBUILD
index 81ba21f044e5..318748b9715a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
pkgname=xyscan
-pkgver=3.3.3
-pkgrel=2
+pkgver=4.0.0
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Tool to extract data points from graphical plots'
-url='http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/'
+url='http://rhig.physics.yale.edu/~ullrich/software/xyscan/'
license=('GPL')
-depends=('qt5-multimedia>=5.2.0')
-source=(http://rhig.physics.yale.edu/~ullrich/software/$pkgname/Distributions/3.33/$pkgname-3.33-src.tar.gz
- xyscan-$pkgver-docs.patch
+depends=('qt5-multimedia>=5.2.0' 'poppler-qt5')
+source=(http://rhig.physics.yale.edu/~ullrich/software/$pkgname/Distributions/4.00/$pkgname-4.00-src.tar.gz
xyscan.desktop)
-md5sums=('d236ee95950edbf0dfef895ea59aafcd'
- '22093f1c22b73f95de1cbfee14d74dc4'
+md5sums=('57000c8e4192c9185647ffb37fad6eca'
'2df01c952f8425d05e0d138778ca5be9')
install=xyscan.install
+prepare() {
+ cd $pkgname
+ sed -i 's:/usr/local/share/xyscan/docs:/usr/share/doc/xyscan:' xyscanWindow.cpp
+ sed -i 's:/usr/local:/usr:' xyscan.pro
+}
+
build() {
cd $pkgname
- patch -i ../$pkgname-$pkgver-docs.patch
qmake-qt5
make
}
@@ -25,9 +28,8 @@ build() {
package() {
cd $pkgname
install --mode=755 -D xyscan $pkgdir/usr/bin/xyscan
- install --mode=755 --directory $pkgdir/usr/share/doc/xyscan/{en,fr}
- install --mode=644 --target-directory=$pkgdir/usr/share/doc/xyscan/en docs/en/*
- install --mode=644 --target-directory=$pkgdir/usr/share/doc/xyscan/fr docs/fr/*
+ install --mode=755 --directory $pkgdir/usr/share/doc/xyscan
+ install --mode=644 --target-directory=$pkgdir/usr/share/doc/xyscan docs/*
install --mode=644 -D images/xyscanIcon.png $pkgdir/usr/share/pixmaps/xyscan.png
if test -x /usr/bin/desktop-file-install; then
/usr/bin/desktop-file-install --dir $pkgdir/usr/share/applications $srcdir/xyscan.desktop
diff --git a/xyscan-3.3.3-docs.patch b/xyscan-3.3.3-docs.patch
deleted file mode 100644
index de105a14b775..000000000000
--- a/xyscan-3.3.3-docs.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- xyscanWindow.cpp.orig 2011-05-16 03:22:20.000000000 +0000
-+++ xyscanWindow.cpp 2011-06-28 10:51:46.034524709 +0000
-@@ -396,27 +396,9 @@
- {
- mHelpBrowser = 0;
-
-- QString path = qApp->applicationDirPath() + "/docs";
-+ QString path = "/usr/share/doc/xyscan";
- QDir dir(path);
- if (!dir.exists()) {
-- path = qApp->applicationDirPath() + "/../docs";
-- dir.setPath(path);
-- }
--#if defined(Q_OS_MAC)
-- if (!dir.exists()) {
-- path = qApp->applicationDirPath() + "/../Resources/docs";
-- dir.setPath(path);
-- }
--#endif
-- //
-- // For developing on Mac/Xcode only: avoids having to copy
-- // the docs into the build substructure.
-- //
-- if (!dir.exists()) {
-- path = "/Users/ullrich/Documents/Projects/xyscan/docs";
-- dir.setPath(path);
-- }
-- if (!dir.exists()) {
- QMessageBox::warning( 0, "xyscan",
- tr("Cannot find the directory holding the documentation (docs). "
- "No online help will be available. "