summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD36
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a34f4a2e7af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 04:15:56 UTC 2016
+pkgbase = yafaray-experimental
+ pkgdesc = A free open-source montecarlo raytracing engine.
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://yafaray.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ makedepends = swig
+ makedepends = python
+ depends = libxml2
+ depends = libjpeg
+ depends = libpng
+ depends = libtiff
+ depends = openexr
+ depends = freetype2
+ depends = zlib
+ optdepends = python: Python bindings
+ provides = yafaray
+ conflicts = yafaray
+ conflicts = yafaray-git
+ source = https://github.com/DavidBluecame/Core/archive/v2.1.1.tar.gz
+ md5sums = 1d0541629c48944e8a397d4ea4d2ccee
+
+pkgname = yafaray-experimental
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1d9f17f606f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+
+pkgname='yafaray-experimental'
+pkgver='2.1.1'
+pkgrel='1'
+pkgdesc='A free open-source montecarlo raytracing engine.'
+arch=('i686' 'x86_64')
+url='http://yafaray.org/'
+license=('LGPL2.1')
+depends=('libxml2' 'libjpeg' 'libpng' 'libtiff' 'openexr' 'freetype2' 'zlib')
+makedepends=('cmake' 'swig' 'python')
+optdepends=('python: Python bindings')
+provides=('yafaray')
+conflicts=('yafaray' 'yafaray-git')
+source=('https://github.com/DavidBluecame/Core/archive/v2.1.1.tar.gz')
+md5sums=('1d0541629c48944e8a397d4ea4d2ccee')
+
+_srcdir="Core-$pkgver"
+
+build() {
+ cd "$_srcdir"
+
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DYAF_PY_VERSION=3.5 \
+ -DYAF_BINDINGS_PY_DIR=/usr/lib/python3.5 ..
+ make
+}
+
+package() {
+ cd "$_srcdir/build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: