summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff8262cccdda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yagostatus-git
+ pkgdesc = Yet Another i3status replacement written in Go.
+ pkgver = 0.1.0.r0.gd9b3aef
+ pkgrel = 1
+ url = https://github.com/burik666/yagostatus
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = go
+ makedepends = git
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/burik666/yagostatus.git
+ md5sums = SKIP
+
+pkgname = yagostatus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5285ddcf88de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrey Burov <burik666@gmail.com>
+
+pkgname=yagostatus-git
+pkgver=0.1.0.r0.gd9b3aef
+pkgrel=1
+pkgdesc='Yet Another i3status replacement written in Go.'
+arch=('x86_64' 'i686')
+url='https://github.com/burik666/yagostatus'
+license=('GPL3')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+source=('git+https://github.com/burik666/yagostatus.git')
+md5sums=('SKIP')
+_gourl='github.com/burik666/yagostatus'
+
+pkgver() {
+ cd "$srcdir/yagostatus"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ GOPATH="$srcdir" go get -v "$_gourl"
+}
+
+package() {
+ _gitdir="$srcdir/src/$_gourl"
+
+ install -p -m 755 -D -t "$pkgdir/usr/bin/" "$srcdir/bin/yagostatus"
+ install -m 644 -D -t "$pkgdir/usr/share/$pkgname/" "$_gitdir/README.md"
+ install -m 644 -D -t "$pkgdir/usr/share/$pkgname/" "$_gitdir/yagostatus.yml"
+}