summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--yamagi-quake2-rogue.desktop9
-rw-r--r--yamagi-quake2-rogue.install9
-rw-r--r--yamagi-quake2-rogue.sh3
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f5acae0aa64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = yamagi-quake2-rogue-git
+ pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)
+ pkgver = 2.01.r0.gf749f68
+ pkgrel = 1
+ url = http://www.yamagi.org/quake2/
+ install = yamagi-quake2-rogue.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = sh
+ depends = yamagi-quake2
+ provides = yamagi-quake2-rogue
+ conflicts = yamagi-quake2-rogue
+ source = yamagi-quake2-rogue::git+https://github.com/yquake2/rogue.git
+ source = yamagi-quake2-rogue.sh
+ source = yamagi-quake2-rogue.desktop
+ sha256sums = SKIP
+ sha256sums = 7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a
+ sha256sums = e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959
+
+pkgname = yamagi-quake2-rogue-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f11768e4e850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=yamagi-quake2-rogue-git
+pkgver=2.01.r0.gf749f68
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)"
+url="http://www.yamagi.org/quake2/"
+license=('GPL' 'custom')
+depends=('sh' 'yamagi-quake2')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install=${pkgname%-*}.install
+source=(${pkgname%-*}::"git+https://github.com/yquake2/rogue.git"
+ "${pkgname%-*}.sh"
+ "${pkgname%-*}.desktop")
+sha256sums=('SKIP'
+ '7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a'
+ 'e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --long --tags | sed 's/^ROGUE_//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ make -C ${pkgname%-*}
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ # game launcher
+ install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+
+ # game library
+ install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/rogue/game.so
+
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+
+ # desktop entry
+ install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/yamagi-quake2-rogue.desktop b/yamagi-quake2-rogue.desktop
new file mode 100644
index 000000000000..b4037943d658
--- /dev/null
+++ b/yamagi-quake2-rogue.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Yamagi Quake II - Mission Pack 2 (rogue)
+Comment=Ground Zero
+Icon=yamagi-quake2
+Exec=yamagi-quake2-rogue
+Categories=Game;Shooter;
+Terminal=false
+StartupNotify=false
diff --git a/yamagi-quake2-rogue.install b/yamagi-quake2-rogue.install
new file mode 100644
index 000000000000..e0729fc62c08
--- /dev/null
+++ b/yamagi-quake2-rogue.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "You need Quake II - Mission Pack 2 ('Ground Zero') data files to play,"
+ echo "copy them to '~/.yq2/rogue'."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/yamagi-quake2-rogue.sh b/yamagi-quake2-rogue.sh
new file mode 100644
index 000000000000..24f783994374
--- /dev/null
+++ b/yamagi-quake2-rogue.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec yamagi-quake2 +set game rogue $*